现在的位置: 首页 > 综合 > 正文

poj_1836Alignment

2013年10月15日 ⁄ 综合 ⁄ 共 2023字 ⁄ 字号 评论关闭
Alignment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10423   Accepted: 3329

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned
in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new
line, where each soldier can see by looking lengthwise the line at least one of the line's extremity (left or right). A soldier see an extremity if there isn't any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of
the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4
#include<iostream>
#include<cstdio>
#include<map>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
#include<set>
#include<string>
#include<queue>
#include <stack>
using namespace std;
#pragma warning(disable : 4996)
const int MAXN = 1005;

int main()
{
	freopen("in.txt", "r", stdin);
	int n;
	int dp_x[MAXN] = {0};
	int dp_y[MAXN] = {0};
	double arr[MAXN] = {0.0};
	while (cin >> n)
	{
		for(int i = 1; i <= n; i++)
		{
			cin >> arr[i];
		}
		for(int i = 1; i <= n; i++) //正序
		{
			dp_x[i] = 1;
			for(int j = 1; j < i; j++)
			{
				if(arr[i] > arr[j] && dp_x[j] + 1 > dp_x[i])
				{
					dp_x[i] = dp_x[j] + 1;
				}
			}
		}

		for(int i = n; i >= 1; i--)//逆序
		{
			dp_y[i] = 1;
			for(int j = n; j > i; j--)
			{
				if(arr[i] > arr[j] && dp_y[j] + 1 > dp_y[i])
				{
					dp_y[i] = dp_y[j] + 1;
				}
			}
		}	

		int ans = 0;
		for(int i = 1; i <= n; i++)
		{
			for(int j = i + 1; j <= n; j++)
			{
				ans = max(ans, dp_x[i] + dp_y[j]);
			}
		}
		cout << n - ans << endl;
	}
	return 0;
}

抱歉!评论已关闭.