现在的位置: 首页 > 综合 > 正文

poj–1703/2492 (经典并查集)

2013年06月15日 ⁄ 综合 ⁄ 共 2885字 ⁄ 字号 评论关闭

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18126   Accepted: 5330

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

此题的意思就是要吧嫌疑犯分成两个团伙。其实这道题就是求给的一个图是不是二分图。。。。








//CODE: POJ_1703 652K	516MS

#include<iostream>
using namespace std;

int f[100010];

//相对于父节点的性质,true表示是同伙,false表示不是同伙
bool sex[100010];	

//返回父节点,以及相对于父节点的性质
int find(int x,bool &se)	
{
	se=true;
	int r=x;
	while(x!=f[x])
	{
		if(sex[x]==false)
			se=!se;
		x=f[x];
	}
	//以下这两句没加之前超时,加了之后516MS,状态压缩的作用
	f[r]=x;			
	sex[r]=se;
	return x;
}
int main()
{
	int t,i,n,m,a,b,cnt=1;
	scanf("%d",&t);
	char str[3];
	while (t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			f[i]=i,sex[i]=true;
		bool judge=true;
		while(m--)
		{
			scanf("%s%d%d",str,&a,&b);
			bool l1=0,l2=0;
			//查询当前节点相对于父节点的性质
			int fa=find(a,l1),fb=find(b,l2);
			if(str[0]=='D')
			{
				//合并两个集合
				f[fa]=fb;
				//经观察,当2个节点相对于父节点的性质都是true或都是false时,两个父节点不是同伙,反之是同伙
				sex[fa]=l1^l2;
			}
			else
			{
				if(fa==fb)			//在同一个集合里就能确定两个犯人的相对属性
				{
					if(l1==l2)		//是同伙
						printf("In the same gang.\n");
					else
						printf("In different gangs.\n");
				}
				else				//不在同一个集合里无法确定
					printf("Not sure yet.\n");
			}
		}
	}
	return 0;
}

//CODE POJ_2492 176K  735MS

#include<iostream>
using namespace std;

int f[2012];

//相对于父节点的性别,true表示是同性,false表示异性
bool sex[2012];	

int find(int x,bool &se)
{
	se=true;
	int r=x;
	while(x!=f[x])
	{
		if(sex[x]==false)
			se=!se;
		x=f[x];
	}
	//以下这两句没加之前2016MS,加了之后735MS,状态压缩的作用
	f[r]=x;
	sex[r]=se;
	return x;
}
int main()
{
	int t,i,n,m,a,b,cnt=1;
	scanf("%d",&t);
	while (t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			f[i]=i,sex[i]=true;
		bool judge=true;
		while(m--)
		{
			scanf("%d%d",&a,&b);
			if(judge)			//未异常
			{
				bool l1=0,l2=0;
				//查询当前节点相对于父节点的性别
				int fa=find(a,l1),fb=find(b,l2);
				if(fa==fb)
				{
					if(l1==l2)
						judge=false;
				}
				else
				{
					//合并两个集合
					 f[fa]=fb;
					 //经观察,当2个节点相对于父节点的性质都是true或都是false时,两个父节点异性,反之是同性
					 sex[fa]=l1^l2;
				}
			}
		}
		printf("Scenario #%d:\n",cnt++);
		if(judge)
			printf("No suspicious bugs found!\n\n");
		else
			printf("Suspicious bugs found!\n\n");
	}
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.