现在的位置: 首页 > 综合 > 正文

HDU 1016Prime Ring Problem简单dfs

2013年11月07日 ⁄ 综合 ⁄ 共 1462字 ⁄ 字号 评论关闭

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20966    Accepted Submission(s): 9386


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 


Input
n (0 < n < 20).
 


Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

 


Sample Input
6 8
 


Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 


Source
 
简单DFS直接上代码:

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
using namespace std;
int visi[20];
int n;
int res[20];

bool isprime(int u)
{
    if(u==0||u==1) return false;
    if(u==2) return true;
    if(u%2==0) return false;
    for(int i=3;i<=sqrt(double(u));i+=2)
        if(u%i==0)
         return false;
    return true;
}

void dfs(int p,int step)
{
    int i;
    if(step==n)
    {
        if(isprime(p+1))
        {
            cout<<res[1];
            for(i=2;i<=n;i++)
                cout<<" "<<res[i];
            cout<<endl;
        }
        return;
    }
    for(i=2;i<=n;i++)
    {
        if(!visi[i]&&isprime(i+res[step]))
        {
            visi[i]=1;
            res[step+1]=i;
            dfs(i,step+1);
            visi[i]=0;
        }
    }
}

int main()
{
    int cas=0;
    while(~scanf("%d",&n))
    {
        memset(visi,0,sizeof(visi));
        printf("Case %d:\n",++cas);
        visi[1]=1;
        res[1]=1;
        dfs(1,1);
        cout<<endl;
    }
    return 0;
}

//890MS 284K

抱歉!评论已关闭.