现在的位置: 首页 > 综合 > 正文

HDU 1003 Max Sum (简单DP入门)

2013年11月05日 ⁄ 综合 ⁄ 共 1675字 ⁄ 字号 评论关闭

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 110957    Accepted Submission(s): 25601

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6

Author
Ignatius.L
题意:求最大连续子序列和。
分析:
要找出和最大的子段,首先想到的是枚举,枚举的方法是,分别将数串中的每一个数作为子段的第一位数,然后子段长度依次递增。例如:

(2,-3,4,-1)这个数串枚举的所有情况为:
以2作为子段的第一位:     2,(2,-3),(2,-3,4),(2,-3,4,-1)。
以-3作为子段的第一位:  -3,(-3,4),(-3,4,-1)。
以4作为子段的第一位:     4,(4,-1)。
以-1作为子段的第一位:  -1 。
从枚举的过程中发现:
当前子段和的值为负值时,就没必要再往下进行,而应将下一位数作为子段的第一位。也就是说,当处理第i个数时,如果以第i-1个数为结尾的子段的和为正数,则不必将第i个数作为新子段的首位进行枚举,因为新子段加上前面子段和所得的正数,一定能得到更大的子段和。
 
代码:
#include<cstdio>

int main()
{
    int t,n,k,sum,temp_position,start,endd,num;
    scanf("%d",&t);
    for(k=1;k<=t;k++)
    {
        scanf("%d",&n);
        sum=0;
        temp_position=1;
        int ans=-1010;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num);
            sum += num;
            
            if(sum > ans)
            {
                ans=sum;
                start=temp_position;
                endd=i;
            }
            if(sum<0)
            {
                sum=0;
                temp_position=i+1;
            }
        }
        printf("Case %d:\n",k);
        printf("%d %d %d\n",ans,start,endd);
        if(k!=t)
            printf("\n");
    }
    return 0;
}

感想:
1、这题其实真的很能反映“动态规划”最优子结构的特点。。。
2、动规的题,我感觉这只能算是第2题。。。还在找感觉。。。

抱歉!评论已关闭.