现在的位置: 首页 > 综合 > 正文

stars

2013年10月07日 ⁄ 综合 ⁄ 共 2512字 ⁄ 字号 评论关闭

      

      

Stars

TimeLimit: 1000MS            Memory Limit:65536K

TotalSubmissions: 25392             Accepted:11095

Description

Astronomers often examine star maps wherestars are represented by points on a plane and each star has Cartesiancoordinates. Let the level of a star be an amount of the stars that are nothigher and not to the right of the given star. Astronomers want to know
thedistribution of the levels of the stars.

 

For example, look at the map shown on thefigure above. Level of the star number 5 is equal to 3 (it's formed by threestars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and4 are 1. At this map there are only one star of the level
0, two stars of thelevel 1, one star of the level 2, and one star of the level 3.

 

You are to write a program that will countthe amounts of the stars of each level on a given map.

 

Input

The first line of the input file contains anumber of stars N (1<=N<=15000). The following N lines describecoordinates of stars (two integers X and Y per line separated by a space,0<=X,Y<=32000). There can be only one star at one point of the plane.Stars
are listed in ascending order of Y coordinate. Stars with equal Ycoordinates are listed in ascending order of X coordinate.

 

Output

The output should contain N lines, onenumber per line. The first line contains amount of stars of the level 0, thesecond does amount of stars of the level 1 and so on, the last line containsamount of stars of the level N-1.

 

Sample Input

 

5

1 1

5 1

7 1

3 3

5 5

 

Sample Output

 

1

2

1

1

0

 

Hint

This problem has huge input data,usescanf() instead of cin to read data to avoid time limit exceed.

评测链接:http://poj.org/problem?id=2352

解法:

一道基础的入门线段树。

用sum【】记录区间内有多少个点,total【】记录每一级有多少个点,x[i]记录i的x坐标(我习惯线段树的区间从1开始,所以读入的x[i]都加了个1),y就不用记录了。

题上说所有的点都是按y从小到大,y相同时,按x从小到大,所以每读入一个点i,x[i]左边有多少个点,i点就是多少级。查询1到x[i]有多少个点用线段树进行解决。对于线段树的节点值的维护,我是一边查找就一边维护了。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cctype>
#define maxn1 (32000+100)
#define maxn2 (15000+100)
using namespace std;

int n,mx;//mx记录出现过的最大的x坐标值 
int x[maxn2],sum[maxn1*3],total[maxn2];
//sum记录维护区间内有多少个点,total记录各级点的个数 
void init()
{
  freopen("stars.in","r",stdin);
  freopen("stars.out","w",stdout);
}
//手写读入输出 
inline int getin()
{
  int ans=0;char tmp;
  do tmp=getchar();
  while(!isdigit(tmp));
  do ans=(ans<<3)+(ans<<1)+tmp-'0';
  while(isdigit(tmp=getchar()));
  return ans;
}
//在区间【pl,pr】中查询i号点左边有多少个点 
int get(int p,int pl, int pr,int i)
{
  sum[p]++;
  if(pl==pr && pr==i)return sum[p]-1;
  int m=(pl+pr)>>1,k=p<<1;
  if(i<=m)return get(k,pl,m,i);
  if(i>m)return sum[k]+get(k+1,m+1,pr,i);
}

void work()
{
  int i,j;  mx=0;  n=getin();  
  for(i=1;i<=n;i++)
     {
       x[i]=getin()+1,j=getin();
       mx=max(mx,x[i]);
     }        
  memset(sum,0,sizeof(int)*((mx+10)*2));
  memset(total,0,sizeof(int)*n);
  for(i=1;i<=n;i++)total[get(1,1,mx,x[i])]++;
  for(i=0;i<n;i++)printf("%d\n",total[i]);
}

int main()
{
  init();
  work();
  return 0;
}

抱歉!评论已关闭.