现在的位置: 首页 > 综合 > 正文

Count the Colors

2013年10月12日 ⁄ 综合 ⁄ 共 2597字 ⁄ 字号 评论关闭
ZOJ Problem Set - 1610

Count the Colors


Time Limit: 2 Seconds     
Memory Limit:
65536 KB


Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.

Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.

Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.

Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1

Sample Output

1 1
2 1
3 1

1 1

0 2
1 1


Author: Standlove

Source: ZOJ Monthly, May 2003

评测连接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1610

解法:裸的线段树,我是从1到n进行染色,用到一种被称为懒标记的优化方法。当然,从n到1倒着染色也可以。

用color[]来维护线段树中的节点,用点i+1来表示线段【i,i+1】,color[i]==-1代表线段未被染色,color[i]==-2代表线段上不止一种颜色,color[i]>=0代表线段只被color[i]颜色所染。

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn (8000+100)
/*
  #define maxn 8000+100---->maxn*4==8000+100*4
  #define maxn (8000+100)---->maxn*4==(8000+100)*4
*/
using namespace std;

int n,last=-1,lasts=-1,cmax=0,dmax=0;
int x[maxn],y[maxn],c[maxn];
int sum[maxn],color[maxn*4];

void init()
{
  freopen("color.in","r",stdin);
  freopen("color.out","w",stdout);
}

void paint(int p,int pl,int pr,int l,int r,int s)
{
  if(l>r)return;
  if(l>pr || r<pl)return;
  if(l<=pl && pr<=r){color[p]=s;return;}
  int m=(pl+pr)>>1,k=p<<1;
  if(color[p]!=-2)//单需要对区间p进行一定改动时,才把p的信息传给子节点,俗称懒标记 
    {
      color[k]=color[k+1]=color[p];
      color[p]=-2;
    }
  if(l<=m)paint(k,pl,m,l,r,s);
  if(r>m)paint(k+1,m+1,pr,l,r,s);  
}

void find(int p,int l,int r)
{
  if(l>r)return;
  if(color[p]>=-1)
    {   //即使color[p]==-1,只是sum[-1]加1
      if(color[p]!=last)++sum[color[p]],last=color[p];
      return;
    }
  if(l==r)return; 
  if(color[p]!=-2)//这里也需要向下传标记,因为可能出现用到区间p1,但p1的父亲并未把节点 
    color[p<<1]=color[(p<<1)+1]=color[p];//信息向下传达,也就是p1线段应为颜色i,但查找时color[p1]却是等于-1的情况     
  int m=(l+r)>>1,k=p<<1;
  find(k,l,m),find(k+1,m+1,r);
}

void work()
{
  memset(sum,0,sizeof(sum));
  memset(color,-1,sizeof(color));
  int i;
  for(i=1;i<=n;i++)
    {//用点i+1代表线段[i,i+1]; 
      scanf("%d%d%d",&x[i],&y[i],&c[i]);x[i]++;
      cmax=max(cmax,c[i]); dmax=max(dmax,y[i]);
    }
  //染色 
  for(i=1;i<=n;i++)paint(1,1,dmax,x[i],y[i],c[i]);
  find(1,1,dmax);//记录每种颜色有多少段 
  for(i=0;i<=cmax;i++)if(sum[i])printf("%d %d\n",i,sum[i]); 
  printf("\n");
}

int main()
{
  init();
  while(scanf("%d",&n)!=EOF)work();
  return 0;  
}

抱歉!评论已关闭.