现在的位置: 首页 > 综合 > 正文

hdu 1331 Function Run Fun(DP)

2013年12月11日 ⁄ 综合 ⁄ 共 1557字 ⁄ 字号 评论关闭

Function Run Fun

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1475    Accepted Submission(s): 752

Problem Description
We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

 

 

Input
The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.
 

 

Output
Print the value for w(a,b,c) for each triple.
 

 

Sample Input
1 1 1 2 2 2 10 4 6 50 50 50 -1 7 18 -1 -1 -1
 

 

Sample Output
w(1, 1, 1) = 2 w(2, 2, 2) = 4 w(10, 4, 6) = 523 w(50, 50, 50) = 1048576 w(-1, 7, 18) = 1
 

 

Source
 

 

Recommend
Ignatius.L
 

思路:水题一道,记忆化搜索

 

#include<iostream>
#include<cstring>
using namespace std;
const int mm=24;
int w[mm][mm][mm];
int dfs(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)return 1;
    if(a>20||b>20||c>20)return dfs(20,20,20);
    if(w[a][b][c])return w[a][b][c];
    if(a<b&&b<c)w[a][b][c]=dfs(a,b,c-1)+dfs(a,b-1,c-1)-dfs(a,b-1,c);
    else w[a][b][c]=dfs(a-1,b,c)+dfs(a-1,b-1,c)+dfs(a-1,b,c-1)-dfs(a-1,b-1,c-1);
    return w[a][b][c];
}
int main()
{
    memset(w,0,sizeof(w));
    int a,b,c;
    while(cin>>a>>b>>c)
    {
        if(a==-1&&b==-1&&c==-1)break;
        cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<dfs(a,b,c)<<"\n";
    }
}

 

 

 

 

抱歉!评论已关闭.