现在的位置: 首页 > 综合 > 正文

hdu 2795 Billboard(线段树)

2013年12月05日 ⁄ 综合 ⁄ 共 2405字 ⁄ 字号 评论关闭

Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4292 Accepted Submission(s): 2003

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't
be put on the billboard, output "-1" for this announcement.

Sample Input
3 5 5 2 4 3 3 3

Sample Output
1 2 1 3 -1

Author
hhanger@zju

Source

Recommend
lcy
当h>n时只需要开n大小的线段树即可
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 200100
using namespace std;
class node
{
  public:
  int l,r,ma;
}root[4*N];
int n,q;
int M;
void build(int t,int l,int r,int m)
{
  root[t].l=l;root[t].r=r;
  if(root[t].l==root[t].r)root[t].ma=m;
  else
  {
    build(t<<1,l,(l+r)/2,m);build(t<<1|1,(l+r)/2+1,r,m);
    root[t].ma=max(root[t<<1].ma,root[t<<1|1].ma);
  }
}
void update(int t,int pos)
{
  int s;
  if(root[t].l==root[t].r&&root[t].ma>=pos){M=root[t].l;root[t].ma-=pos;return;}
  if(root[t].ma<pos){return;}
  else
  {
    if(root[t<<1].ma>=pos)update(t<<1,pos);
    else update(t<<1|1,pos);
    root[t].ma=max(root[t<<1].ma,root[t<<1|1].ma);
  }
}
int main()
{
  int m,a;
  while(scanf("%d%d%d",&n,&m,&q)!=EOF)
  {
    if(n>N)
    n=N-10;
    build(1,1,n,m);
    for(int i=0;i<q;i++)
    {
      M=-1;
      scanf("%d",&a);
      update(1,a);
      printf("%d\n",M);
    }
  }
}

抱歉!评论已关闭.