现在的位置: 首页 > 综合 > 正文

2528 Mayor’s posters 线段树的覆盖问题 判断一段区间是否被覆盖

2013年08月15日 ⁄ 综合 ⁄ 共 3766字 ⁄ 字号 评论关闭
 

Mayor's posters
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 13937  Accepted: 3875

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.
Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

 

 

 

 

//

//这道题真是DT啊,开的数组到了100K还是不行,得到1000k才能过啊,最可气的是用C++提交是WA,而G++是RE;
//哥一直用C++,导致哥修改了1天也没发现错误,还是符COW发现数组开小的,感谢符COW,自己以后也会注意一下的。
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct point
{
    int l,r;
}pos[1000000];
struct node
{
    int left,right;
    bool becovered;
};
node tree[1000000];
int n;
int lsh[10000010],x[1000000];
void buildtree(int id,int l,int r)
{
    tree[id].left=l;
    tree[id].right=r;
    tree[id].becovered=0;
    if(l!=r)
    {
        buildtree(2*id,l,(l+r)/2);
        buildtree(2*id+1,(l+r)/2+1,r);
    }
}
bool search_update_notbecovered(int id,int l,int r)
{
    if(tree[id].becovered) return 0;
    if(tree[id].left==l&&tree[id].right==r)//update
    {
        tree[id].becovered=1;
        return 1;
    }
    bool flag;
    if(r<=(tree[id].left+tree[id].right)/2) flag=search_update_notbecovered(2*id,l,r);
    else if(l>=(tree[id].left+tree[id].right)/2+1) flag=search_update_notbecovered(2*id+1,l,r);
    else
    {
        bool f1,f2;
        f1=search_update_notbecovered(2*id,l,(tree[id].left+tree[id].right)/2);
        f2=search_update_notbecovered(2*id+1,(tree[id].left+tree[id].right)/2+1,r);
        flag=f1||f2;
    }
    if(tree[2*id].becovered&&tree[2*id+1].becovered)
    {
        tree[id].becovered=1;
    }
    return flag;
}
int main()
{
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        n=0;
        int cci;scanf("%d",&cci);
        for(int i=0;i<cci;i++)
        {
            scanf("%d%d",&pos[i].l,&pos[i].r);
            x[n++]=pos[i].l;
            x[n++]=pos[i].r;
        }
        sort(x,x+n);
        int l=1;
        lsh[x[0]]=l;
        for(int i=1;i<n;i++)
        {
            if(x[i-1]==x[i]) continue;
            else
            {
                if(x[i-1]+1<x[i]) ++l;
                lsh[x[i]]=++l;
            }
        }
        n=l;
        buildtree(1,1,n);
        int cnt=0;
        for(int i=cci-1;i>=0;i--)
        {
            if(search_update_notbecovered(1,lsh[pos[i].l],lsh[pos[i].r]))
            {
                cnt++;
            }
        }
        printf("%d/n",cnt);
    }
    return 0;
}

 

 

抱歉!评论已关闭.