现在的位置: 首页 > 综合 > 正文

poj 3694 Network 求加边后还剩多少桥

2013年01月22日 ⁄ 综合 ⁄ 共 3346字 ⁄ 字号 评论关闭

http://poj.org/problem?id=3694

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0
Sample Output

Case 1:
1
0

Case 2:
2
0

 

 

#include<cstdio>

#include<cstring>

#include<algorithm>

using namespace std;

//求加边后还剩多少桥

//若加的边属于某边双连通分支,肯定不会减少桥的数目,而桥肯定是树边,它会将一棵

//子树与祖先割开,若加边(u,v),那么,u和v所在链将成为一个环,此环上必不存在

//桥,因此,每添加一条边,从u,v跑上lca将桥标记掉,并修改答案

const int MAXN=100010;

 

 

 

 

struct Node{

    int v,next;

}nodes[MAXN*4];

 

 

int G[MAXN];

int level[MAXN],low[MAXN];

int vi[MAXN],fa[MAXN];

int cut[MAXN],isBridge[MAXN*4];

int alloc,n,m,bridgeNum;

 

 

void add(int a,int b){

    alloc++;

    nodes[alloc].v=b,nodes[alloc].next=G[a];

    G[a]=alloc;

}

 

 

void dfs(int u,int dep){

    vi[u]=1;

    level[u]=low[u]=dep;

    bool flag=true;

    //if(u!=1)cut[u]++;

    for(int son=G[u];son;son=nodes[son].next){

        int v=nodes[son].v;

        if(v==fa[u]&&flag){

            flag=false;

            continue;

        }

        if(vi[v]==1)

            low[u]=min(low[u],level[v]);

        else if(vi[v]==0){

            fa[v]=u;

            dfs(v,dep+1);

            low[u]=min(low[u],low[v]);

            //if(low[v]>=level[u])cut[u]++;

            if(low[v]>level[u]){//bridge

                isBridge[v]=1;

                bridgeNum++;

            }

        }

    }

    vi[u]=2;

}

void lca(int x,int y){

    if(level[x]<level[y])swap(x,y);

    while(level[x]>level[y]){

        if(isBridge[x]){

            bridgeNum--;

            isBridge[x]=0;

        }

        x=fa[x];

    }

    while(x!=y){

        if(isBridge[x]){bridgeNum--;isBridge[x]=0;}

        if(isBridge[y]){bridgeNum--;isBridge[y]=0;}

        x=fa[x];y=fa[y];

    }

}

int main(){

    int a,b,t=1;

    while(scanf("%d%d",&n,&m),n){

        alloc=0;

        memset(G+1,0,sizeof(int)*n);

        while(m--){

            scanf("%d%d",&a,&b);

            add(a,b);

            add(b,a);

        }

        memset(vi,0,sizeof(vi));

        memset(isBridge,0,sizeof(isBridge));

        bridgeNum=0;

        fa[1]=1;

        dfs(1,0);

        printf("Case %d:\n",t++);

        scanf("%d",&m);

        while(m--){

            scanf("%d%d",&a,&b);

            lca(a,b);

            printf("%d\n",bridgeNum);

        }

        puts("");

    }

    return 0;

}

 

抱歉!评论已关闭.