现在的位置: 首页 > 综合 > 正文

POJ 2312 Battle City bfs宽搜

2013年10月02日 ⁄ 综合 ⁄ 共 2710字 ⁄ 字号 评论关闭

 类似"罗密欧与朱丽叶"那题,宽搜搞定。

Battle City
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5858   Accepted: 1934

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.

 


What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).

 


Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you
can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear
(i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target),
'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int S=310;
int h[S][S];
char g[S][S];
int dx[4]={1,0,-1,0};
int dy[4]={0,1,0,-1};
struct point{
    int x,y,step;
    friend bool operator < (const point &a, const point &b){
        return (a.step<b.step?0:1);
    }
};
int fun(point begin,point end,int m,int n,char g[][S]){
    int x,y,i,step;
    point now,tmp;
    memset(h,-1,sizeof(h));
    h[begin.x][begin.y]=0;
    priority_queue<point> q;
    q.push(begin);
    while (!q.empty()){
        now=q.top();
 //       printf("(%d , %d)  step=%d\n",now.x,now.y,now.step);
        q.pop();
        for (i=0;i<4;i++){
            x=now.x+dx[i];
            y=now.y+dy[i];
            if (x<0||y<0||x>=m||y>=n) continue;
            if (g[x][y]=='S'||g[x][y]=='R') continue;
            if (g[x][y]=='B') {
                tmp.x=x;tmp.y=y;tmp.step=now.step+2;
                if (h[x][y]>tmp.step||h[x][y]==-1){
                    q.push(tmp);
                    h[x][y]=tmp.step;
                }
            }
            if (g[x][y]=='E'||g[x][y]=='T') {
                tmp.x=x;tmp.y=y;tmp.step=now.step+1;
                if (h[x][y]>tmp.step||h[x][y]==-1){
                    q.push(tmp);
                    h[x][y]=tmp.step;
                }
            }
        }
    }
    return 0;
}
int main(){
    point begin,end;
    int m,n,i,j;
    while (scanf("%d%d",&m,&n),!(m==0&&n==0)){
        for (i=0;i<m;i++)
            scanf("%s",g[i]);
        for (i=0;i<m;i++)
            for (j=0;j<n;j++)
            {
                if (g[i][j]=='Y') {begin.x=i;begin.y=j;begin.step=0;}
                if (g[i][j]=='T') {end.x=i;end.y=j;}
            }
        fun(begin,end,m,n,g);
        printf("%d\n",h[end.x][end.y]);
   /*     for (i=0;i<m;i++){
            for (j=0;j<n;j++)
            {
                printf("%d\t",h[i][j]);
            }
            printf("\n");
        }*/
    }
    return 0;
}

 

 

抱歉!评论已关闭.