现在的位置: 首页 > 综合 > 正文

poj 1269 Intersecting Lines

2013年08月25日 ⁄ 综合 ⁄ 共 2504字 ⁄ 字号 评论关闭

Intersecting Lines
Time Limit: 1000MS   Memory Limit: 10000KB   64bit IO Format: %I64d & %I64u

[Submit]  
[Go
Back
]   [Status]

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they
are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4.
Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point.
If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

[Submit]  
[Go
Back
]   [Status]

Source
Code


Problem: D   User: sdau_09_zys
Memory: 180 KB   Time: 0 MS
Language: C++   Result: Accepted
Public:  

/*
题目:
http://poj.org/problem?id=1269
题目大意:给出四个点确定两条直线。如果是一条线输出“LINE”,如果平行输出“NONE”, 如果有交点输出交点坐标。
思路:注意是直线,不是线段啊。
用两点式推出两条直线方程 :
(y1 - y2)x + (x2 - x1)y = x2y1 - x1y2;
(y3 - y4)x + (x4 - x3)y = x4y3 - x3y4;
又由Cramer法则:
a1x + b1y = c1;
a2x + b2y = c2;
D = a1b2 - a2b1; D1 = c1b2 - c2b1; D2 = a1c2 - a2c1;
D != 0时, x = D1 / D, y = D2 / D; 得到交点坐标。
D = 0时;如果a1 / a2 = b1 / b2 = c1 / c2 , 则四个点在一条直线上;否则两直线平行,无交点。

*/
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int main ()
{
    
int n;
    
int x1, y1, x2, y2, x3, y3, x4, y4;
    
int a1, b1, c1, a2, b2, c2;
    
int D, D1, D2;
    
double x, y;
    
scanf ("%d", &n);
    
printf ("INTERSECTING LINES OUTPUT\n");
    
while (n--)
    
{
        
scanf ("%d%d%d%d%d%d%d%d",&x1, &y1, &x2, &y2, &x3, &y3, &x4, &y4);
        a1
= y1 - y2;                     // 由公式推出的关系
        a2
= y3 - y4;
        b1
= x2 - x1;
        b2
= x4 - x3;
        c1
= x2 * y1 - x1 * y2;
        c2
= x4 * y3 - x3 * y4;

抱歉!评论已关闭.