现在的位置: 首页 > 综合 > 正文

优先队列(UVAL-3135)

2013年11月22日 ⁄ 综合 ⁄ 共 2478字 ⁄ 字号 评论关闭

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone
call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: �Every five minutes, retrieve the maximum temperature over the past five minutes.� Query-2: �Return the average temperature measured on each floor over the past 10 minutes.�

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data
and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_num Period

Q_num (0 < Q_num ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first
time, and after that, the result will be returned every Period seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries
are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input 

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same
time. This part is ended with a line of �#�.

The second part is your task. This part contains only one line, which is one positive integer K (≤ 10000).

Output 

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input 

Register 2004 200
Register 2005 300
#
5

Sample Output 

2004
2005
2004
2004
2005


题目的大概意思是这样的,
Rigister num period
每period就产生一个num事件.
让你求出前k个时间的编号。经典的优先队列维护。

贴出代码:
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>
#include <queue>

using namespace std;

struct node
{
	int num;
	int period;
	int time;
	
	bool operator < (const node& t) const
	{
		if (time != t.time)
		{
			return time > t.time;
		}
		else
		{
			return num > t.num;
		}
	}
}t;

priority_queue <node> Q;

void init()
{
	while (!Q.empty())
	{
		Q.pop();
	}
}

int main()
{
	char str[22];
	init();
	while (scanf("%s", str) == 1)
	{
		if (str[0] == '#')
		{
			break;
		}
		scanf("%d%d", &t.num, &t.period);
		t.time = t.period;
		Q.push(t);
	}
	int k;
	scanf("%d", &k);
	for (int i = 0; i < k; i++)
	{
		t = Q.top();
		Q.pop();
		printf("%d\n", t.num);
		t.time += t.period;
		Q.push(t);
	}	
//	system("pause");
	return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.