现在的位置: 首页 > 综合 > 正文

ZOJ-3710(Friends)

2013年04月27日 ⁄ 综合 ⁄ 共 1787字 ⁄ 字号 评论关闭

Friends


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become
friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many
new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three
integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship
contains two integers ui, vi (0 ≤ ui, vi < nui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4

这可就坑爹了呀。其实我还是没有掌握一种方法,那就是根据数据判断所用的解题方法,

例如这道题目,100的数据,三重for循环也才一点点,而时间限制是2S,这毋庸置疑的只要你知道了暴力的方法,

那么,你就能A掉这个题目,当时就没看出来这个,

所以一直在想啊想啊。最终还是没有想出来。诶。

气死人不偿命呀。

贴出事后的代码吧:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>

using namespace std;

int map[122][122];

int N, K, M;

int main()
{
	int T;
	int a, b;
	while (scanf("%d", &T) != EOF)
	{
		while (T--)
		{
			memset(map, 0, sizeof(map));
			scanf("%d%d%d", &N, &M, &K);
			for (int i = 0; i < M; i++)
			{
				scanf("%d%d", &a, &b);
				map[a][b] = 1;
				map[b][a] = 1;
			}
			int ans = 0;
			while (1)
			{
				int count = 0;
				for (int i = 0; i < N - 1; i++)
				{
					for (int j = i + 1; j < N; j++)
					{
						int cnt = 0;
						if (!map[i][j])
						{
							for (int k = 0; k < N; k++)
							{
								if (map[i][k] && map[j][k])
								{
									cnt++;
								}
							}
							if (cnt >= K && !map[i][j])
							{
								map[i][j] = 1;
								map[j][i] = 1;
//								cout << "i == " << i << "j == " << j << endl;
								count++;
							}
						}
					}
				}
				ans += count;
				if (count == 0)
				{
					break;
				}
			}
			printf("%d\n", ans);		
		}
	}
//	system("pause");
	return 0;
}

抱歉!评论已关闭.