现在的位置: 首页 > 综合 > 正文

hdu2845之Beans,DP

2014年02月28日 ⁄ 综合 ⁄ 共 1304字 ⁄ 字号 评论关闭
Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following
rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.

Now, how much qualities can you eat and then get ?

 


Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 


Output
For each case, you just output the MAX qualities you can eat and then get.
 


Sample Input
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
 


Sample Output
242
先求某一行能获得的最大值,然后求所有行能获得的最大值.
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=200003;
int dpx[MAX],dpy[MAX];//dpx用来存当前这一行前i列最大值,dpy用来存前i行可得最大值.

int main(){
	int n,m,s;
	while(cin>>n>>m){
		for(int i=2;i<=n+1;++i){
			for(int j=2;j<=m+1;++j){
				scanf("%d",&s);
				dpx[j]=max(dpx[j-1],dpx[j-2]+s);//当前这行前j列能获得的最大值. 
			}
			dpy[i]=max(dpy[i-1],dpy[i-2]+dpx[m+1]);//前i行最大能获得的最大值. 
		}
		cout<<dpy[n+1]<<endl;
	}
	return 0;
} 

抱歉!评论已关闭.