现在的位置: 首页 > 综合 > 正文

Ping pong

2014年01月05日 ⁄ 综合 ⁄ 共 2432字 ⁄ 字号 评论关闭

Ping pong

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 643   Accepted: 239

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to
compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the
referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or
any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1 
3 1 2 3

Sample Output

1

Source

 
刚开始的时候用直接暴力枚举的方法,结果不出所料地超时了,找了一下资料,知道可以通过建立树状数组的方法来只枚举referee,
step1.建两个辅助树状数组b[],c[],分别用来存放1到i-1中和i+1到n中的值,一边通过这两个辅助树状数组建立g[],h[]分别分别用来存放1到i-1中和i+1到n中小于referee的a[i]值。
step2.通过所求得的g,h数组根据乘法原理求出满足条件a[j]<a[i]<a[k] or a[j]>a[i]>a[k],j<i<k的所有情况的总数。
 
#include <cstdio>
#include <cstring>
using namespace std;

const int maxm=100000;  //the max skill rank
const int maxn=20000;   //the max number of players

int g[maxn+10],h[maxn+10];//数组g,h分别用来统计1到i-1和i+1到n中skill rank小于referee——a[i]的个数
int b[maxm+10],c[maxm+10];//树状数组b,c分别用来辅助g,h完成统计的功能
int lb[maxm+10];        //辅助数组,存储树状数组每个值的管辖范围

int calcu(int *b,int k){
 int ans=0;
 for(int i=k;i>0;i-=lb[i])
  ans+=b[i];
 return ans;
 }

void insert(int *b,int k){
 for(int i=k;i<=maxm;i+=lb[i])
  ++b[i];
 }

int main(){
 int T,a[maxn+10];
 for(int i=1;i<=maxm;++i)lb[i]=i&(i^(i-1));       //i&(i^(i-1))为树状数组区间分划公式
 scanf("%d",&T);
 while(--T>=0){
  int N;
  scanf("%d",&N);
  memset(b,0,sizeof(b));
  memset(c,0,sizeof(c));
  for(int i=0;i<N;++i)
   scanf("%d",&a[i]);
  for(int i=0;i<N;++i){
   g[i]=calcu(b,a[i]-1);
   insert(b,a[i]);
   }
  for(int i=N-1;i>0;--i){
   h[i]=calcu(c,a[i]-1);
   insert(c,a[i]);
   }
  __int64 ans=0;
  for(int i=1;i<N-1;++i){
   ans+=(__int64)g[i]*(__int64)(N-i-1-h[i])+(__int64)h[i]*(__int64)(i-g[i]);
   }
  printf("%I64d\n",ans);
  }
 return 0;
 }

抱歉!评论已关闭.