现在的位置: 首页 > 综合 > 正文

487-3279

2014年01月22日 ⁄ 综合 ⁄ 共 3402字 ⁄ 字号 评论关闭

                                                                             487-3279
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 176480   Accepted: 30262

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP.
Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could
order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers
in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number
appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

Source

 
 
#include <cstdio>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;

void guige(string &bz)
{
	int k=bz.size(),j=0,i;
	string cz;
	for (i=0;i<k;++i)
	{
		if (bz[i]>='A'&&bz[i]<='Y')
		{
			switch (bz[i])
			{
			case 'A':
			case 'B':
			case 'C':bz[i]='2';break;
			case 'D':
			case 'E':
			case 'F':bz[i]='3';break;
			case 'G':
			case 'H':
			case 'I':bz[i]='4';break;
			case 'J':
			case 'K':
			case 'L':bz[i]='5';break;
			case 'M':
			case 'N':
			case 'O':bz[i]='6';break;
			case 'P':
			case 'R':
			case 'S':bz[i]='7';break;
			case 'V':
			case 'T':
			case 'U':bz[i]='8';break;
			case 'W':
			case 'X':
			case 'Y':bz[i]='9';break;
			default:break;
			}
		}
		if (bz[i]>='0'&&bz[i]<='9')
		{
			if (j==3)
				cz+="-";
			cz+=bz[i];
			++j;
		}
	}
	bz=cz;
}

int main()
{
	long n,k,i,ans[50001],fl;
	memset(ans,0,sizeof(ans));
	char cs[100];
	vector<string> str,str1;
	string st;
	scanf("%d",&n);
	k=n;
	while (--k>=0)
	{
		scanf("%s",cs);
		st=cs;
		guige(st);
		str.push_back(st);
	}
	sort(str.begin(),str.end());
	k=0;
	fl=0;
	for (i=1;i<n;++i)
	{
		if (str[i]!=str[i-1])
		{
			if (i-fl-1>0)
			{
				str1.push_back(str[fl]);
				ans[k++]=i-fl;
			}
			fl=i;
		}
		else if (i==n-1)
		{
			str1.push_back(str[fl]);
			ans[k++]=i-fl+1;
		}
	}
	if (k==0)
	{
		printf("No duplicates.\n");
		return 0;
	}
	for (i=0;i<k;++i)
		printf("%s %d\n",str1[i].c_str(),ans[i]);
	return 0;
}

 

抱歉!评论已关闭.