现在的位置: 首页 > 综合 > 正文

Constructing Roads In JGShining’s Kingdom

2014年01月01日 ⁄ 综合 ⁄ 共 2736字 ⁄ 字号 评论关闭

Constructing Roads In JGShining's Kingdom

Time  Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K  (Java/Others)
Total Submission(s): 6146    Accepted Submission(s):  1786

Problem Description
JGShining's kingdom consists of 2n(n is no more than  500,000) small cities which are located in two parallel lines.

Half of  these cities are rich in resource (we call them rich cities) while the others  are short of resource (we call them poor cities). Each poor city is short of  exactly one kind of resource and also each rich city is rich in exactly one kind  of resource.
You may assume no two poor cities are short of one same kind of  resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from  rich ones. The roads existed are so small that they're unable to ensure the  heavy trucks, so new roads should be built. The poor cities strongly BS each  other, so are the rich ones.
Poor cities don't wanna build a road with other  poor ones, and rich ones also can't abide sharing an end of road with other rich  ones. Because of economic benefit, any rich city will be willing to export  resource to any poor one.

Rich citis marked from 1 to n are located in  Line I and poor ones marked from 1 to n are located in Line II.

The  location of Rich City 1 is on the left of all other cities, Rich City 2 is on  the left of all other cities excluding Rich City 1, Rich City 3 is on the right  of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as  the poor ones.

But as you know, two crossed roads may cause a lot of  traffic accident so JGShining has established a law to forbid constructing  crossed roads.

For example, the roads in Figure I are forbidden.

In order to build as  many roads as possible, the young and handsome king of the kingdom - JGShining  needs your help, please help him. ^_^

Input
Each test case will begin with a line containing an  integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers  p and r which represents that Poor City p needs to import resources from Rich  City r. Process
to the end of file.

Output
For each test case, output the result in the form of  sample.

You should tell JGShining what's the maximal number of road(s) can  be built.

Sample Input
2 1 2 2 1 3 1 2 2 3 3 1

Sample Output
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
这道题是用最长上升子序列的方法来做的,把富人的位置按与穷人的对应关系存入数列,再求它的最长上升子序列的长度,即为所求解,在求最长上升子序列的过程中用了贪心算法的思想,求出限定长度上升子序列的最小尾数,再递推出可求的最长上升子序列。
#include <cstdio>
using namespace std;
#define MAX 500010
int road[MAX],dp[MAX];

int bsearch(int num,int right)
{
    int left=1;
    while (left<=right)
    {
        int mid=(left+right)/2;
        if (num<dp[mid]&&(mid==1||num>dp[mid-1]))
            return mid;
        else if (num<dp[mid])
            right=mid-1;
        else
            left=mid+1;
    }
    return 0;
}

int main()
{
    int n,i,r,k,j=0;
    while (scanf("%d",&n)!=EOF)
    {
        k=n;
        while (--k>=0)
        {
            scanf("%d %d",&i,&r);
            road[i]=r;
            dp[i]=0;
        }
        dp[1]=road[1];
        k=1;
        for (i=2;i<=n;++i)
        {
            if (road[i]>dp[k])
                dp[++k]=road[i];
            else
            {
                r=bsearch(road[i],k);
                dp[r]=road[i];
            }
        }
        printf("Case %d:\n",++j);
        printf("My king, at most %d road%s can be built.\n\n",k,(k-1)?"s":"");
    }
    return 0;
}

抱歉!评论已关闭.