现在的位置: 首页 > 综合 > 正文

ZOJ 1586 QS Network 最小生成树水题

2014年04月05日 ⁄ 综合 ⁄ 共 2714字 ⁄ 字号 评论关闭

点击打开链接

 

 

QS Network

 


 

Time Limit: 2 Seconds                                    
Memory Limit: 65536 KB                            

 


 

Sunny Cup 2003 - Preliminary Round

April 20th, 12:00 - 17:00

Problem E: QS Network

  In the planet w-503 of galaxy cgb, there is a kind of intelligent creature named   QS. QScommunicate with each other via networks. If two QS want to get connected,   they need to buy two network adapters (one for each QS) and a segment of network   cable.
Please be advised that ONE NETWORK ADAPTER CAN ONLY BE USED IN A SINGLE   CONNECTION.(ie. if a QS want to setup four connections, it needs to buy four   adapters). In the procedure of communication, a QS broadcasts its message to   all the QS it is connected
with, the group of QS who receive the message broadcast   the message to all the QS they connected with, the procedure repeats until all   the QS's have received the message.

A sample is shown below:

  A sample QS network, and QS A want to send a message.

  Step 1. QS A sends message to QS B and QS C;

  Step 2. QS B sends message to QS A ; QS C sends message to QS A and QS D;

  Step 3. the procedure terminates because all the QS received the message.

Each QS has its favorate brand of network adapters and always buys the brand   in all of its connections. Also the distance between QS vary. Given the price   of each QS's favorate brand of network adapters and the price of cable between   each pair of QS,
your task is to write a program to determine the minimum cost   to setup a QS network.

Input

The 1st line of the input contains an integer t which indicates the number   of data sets.

  From the second line there are t data sets.

  In a single data set,the 1st line contains an interger n which indicates the   number of QS.

  The 2nd line contains n integers, indicating the price of each QS's favorate   network adapter.

  In the 3rd line to the n+2th line contain a matrix indicating the price of cable   between ecah pair of QS.

Constrains:

all the integers in the input are non-negative and not more than 1000.

Output

for each data set,output the minimum cost in a line. NO extra empty lines needed.

Sample Input

1
  3
  10 20 30
  0 100 200
  100 0 300
  200 300 0

Sample Output

370

 


     Author: JIANG, Jiefeng
   Source: Zhejiang University Local Contest 2003, Preliminary

 

题意:在某个外星球有些叫QS的外星人。他们之间要相互联系。但是要买网络适配器,当然不同的QS喜欢不同价格的适配器。而且还需要买网络电缆,而且都需要费用。让你求用最小的花费去建立他们之间的联系。

 

#include<stdio.h>
#include<string.h>
#define MAX 999999
int map[1007][1007],dis[1007],val[1007];
int t,n;

void prime()
{
	int count=0,min,i,j,pos;
	int vis[1007];
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)
	{
		dis[i]=map[1][i];
	}
	vis[1]=1;
	for(i=1;i<=n;i++)
	{
		min=MAX;
		for(j=1;j<=n;j++)
		if(!vis[j]&&min>dis[j])
		{
			min=dis[j];
			pos=j;
		}
		if(min==MAX)
		{
			printf("%d\n",count);
			return;
		}
		vis[pos]=1;
		count+=min;
		for(j=1;j<=n;j++)
		if(!vis[j]&&dis[j]>map[j][pos])
		dis[j]=map[j][pos];
	}
	printf("%d\n",count);
}

int main()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		int i,j;
		memset(val,0,sizeof(val));
		memset(map,0,sizeof(map));
		for(i=1;i<=n;i++)
		scanf("%d",&val[i]);
		for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
		{
			scanf("%d",&map[i][j]);
			if(i!=j)
			map[i][j]+=val[i]+val[j];
		}
		prime();
	}
	return 0;
}

 

 

 

 

 

抱歉!评论已关闭.