现在的位置: 首页 > 综合 > 正文

ZOJ 1904 Frogger 另一种Dijkstra

2014年04月05日 ⁄ 综合 ⁄ 共 2578字 ⁄ 字号 评论关闭

点击打开链接

 

Frogger

 


 

Time Limit: 2 Seconds                                    
Memory Limit: 65536 KB                            

 


            Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices  Fiona Frog who is sitting on another stone. He plans to visit her, but since the  water is dirty and full of tourists' sunscreen, he wants to avoid swimming
and  instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers  to use other stones as intermediate stops and reach her by a sequence of several  small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at  least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore  is defined as the minimum necessary jump range over all possible paths between  the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other   stones in the lake. Your job is to compute the frog distance between Freddy's   and Fiona's stone.

Input

  The input will contain one or more test cases. The first line of each test case   will contain the number of stones n (2 <= n <= 200). The next n lines   each contain two integers xi, yi (0 <= xi, yi <= 1000) representing the   coordinates of stone #i. Stone
#1 is Freddy's stone, stone #2 is Fiona's stone,   the other n-2 stones are unoccupied. There's a blank line following each test   case. Input is terminated by a value of zero (0) for n.

Output

  For each test case, print a line saying "Scenario #x" and a line saying   "Frog Distance = y" where x is replaced by the test case number (they   are numbered from 1) and y is replaced by the appropriate real number, printed   to three decimals. Put a blank
line after each test case, even after the last   one.

Sample Input

  2
  0 0
  3 4

3
  17 4
  19 4
  18 5

0

Sample Output

  Scenario #1
  Frog Distance = 5.000

Scenario #2
  Frog Distance = 1.414

 

题意:有两只青蛙分别是1号和2号。给你这两只青蛙的位置和他们之间的一些石头的位置,让你求1号青蛙到经过跳跃石头到2号青蛙的最短距离。

#include<stdio.h>
#include<math.h>
#include<string.h>
double dis[1007];
double map[1007][1007];
int n;
struct sa
{
	double a,b;
}forg[1007];

void dijkstra()
{
	int i,j,vis[1007];
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)
	{
		dis[i]=999999;
	}
	dis[1]=0;
	int pos,now=1;
	double t;
	double min;
	vis[now]=1;
	for(i=1;i<=n;i++)
	{
		min=999999;
		for(j=1;j<=n;j++)
		{
			t=dis[now]>map[now][j]?dis[now]:map[now][j];
			if(t<dis[j])
			dis[j]=t;
		}
		for(j=1;j<=n;j++)
		if(!vis[j]&&dis[j]<min)
		{
			min=dis[j];
			now=j;
		}
		vis[now]=1;
	}
	
}

int main()
{
	int textcase=1;
	while(scanf("%d",&n),n)
	{
		int i,j;
		memset(map,0,sizeof(map));
		
		for(i=1;i<=n;i++)
		{
			scanf("%lf%lf",&forg[i].a,&forg[i].b);
		}
		double tmp;
		for(i=1;i<=n;i++)
		for(j=i+1;j<=n;j++)
		{
			if(i==j)
			{
				map[i][j]=999999;
				continue;
			}
			
			tmp=sqrt(pow(forg[j].a-forg[i].a,2.0)+pow(forg[j].b-forg[i].b,2.0));
			map[i][j]=map[j][i]=tmp;
		}
		dijkstra();
		 printf("Scenario #%d\n",textcase++);  
	     printf("Frog Distance = %.3f\n\n",dis[2]);   

	}	
	return 0;
}

 

 

 

 

抱歉!评论已关闭.