现在的位置: 首页 > 综合 > 正文

HDU 1080 Human Gene Functions LCS变形问题

2014年04月05日 ⁄ 综合 ⁄ 共 4114字 ⁄ 字号 评论关闭

点击打开链接

 

 

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1709    Accepted Submission(s): 961

Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining
their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in
determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes
and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that
the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score
the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.



* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

 

 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The
length of each gene sequence is at least one and does not exceed 100.
 

 

Output
The output should print the similarity of each test case, one per line.
 

 

Sample Input
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA
 

 

Sample Output
14 21
 

 

Source

 

题意:

两个字符串,每个字符串中都可以插入'-',保证最后两串的长度相等,之后让两串对齐,两串相同位置的字母组成的字符匹配有一个值,问这些值的和最大是多少。

思路:LCS变形。状态转移方程:dp[i][j]=max(dp[i-1][j]+change(s1[i],'-'),dp[i][j-1]+change('-',s2[j]))和

 dp[i][j]=max(dp[i-1][j-1]+change(s1[i],s2[j]),dp[i][j])。

#include<stdio.h>
#include<string.h>
char s1[107],s2[107];
int len1,len2,dp[107][107],i,j;
int max(int a,int b)
{
	return a>b?a:b;
}
int table[6][6]={
	0,0,0,0,0,0,
	0,5,-1,-2,-1,-3,
	0,-1,5,-3,-2,-4,
	0,-2,-3,5,-2,-2,
	0,-1,-2,-2,5,-1,
	0,-3,-4,-2,-1,-100000,
};
int exchange(char x)
{
	if(x=='A')return 1;
	else if(x=='C')return 2;
	else if(x=='G')return 3;
	else if(x=='T')return 4;
	else return 5;
}
int change(char a,char b)
{
	int x=exchange(a);
	int y=exchange(b);
	return table[x][y];
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		scanf("%d%s",&len1,s1+1);
		scanf("%d%s",&len2,s2+1);
		for(i=1;i<=len1;i++)
		{
			dp[i][0]=dp[i-1][0]+change(s1[i],'-');
		}	
		for(j=1;j<=len2;j++)
		{
			dp[0][j]=dp[0][j-1]+change('-',s2[j]);
		}
		for(i=1;i<=len1;i++)
		for(j=1;j<=len2;j++)
		{
			dp[i][j]=max(dp[i-1][j]+change(s1[i],'-'),dp[i][j-1]+change('-',s2[j]));//比较s1和s2两个字符串哪个插入‘-’后的值大 
			dp[i][j]=max(dp[i-1][j-1]+change(s1[i],s2[j]),dp[i][j]);//比较s1和s2都没有插入’-‘和s1,s2中插入’-‘最大的那个数组 
		}
		printf("%d\n",dp[len1][len2]);
	}
	return 0;
}

 

 

 

抱歉!评论已关闭.