现在的位置: 首页 > 综合 > 正文

UVa 113 Power of Cryptography 数学计算题

2014年06月06日 ⁄ 综合 ⁄ 共 1217字 ⁄ 字号 评论关闭
文章目录

113 - Power of Cryptography

 Power of Cryptography 


Background

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics
once considered to be of only theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

The Problem

Given an integer tex2html_wrap_inline32 and an integertex2html_wrap_inline34
you are to write a program that determinestex2html_wrap_inline36 , the positivetex2html_wrap_inline38
root ofp. In this problem, given such integers n and p,
p will always be of the formtex2html_wrap_inline48 for an integerk (this integer is what your program must find).

The Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairstex2html_wrap_inline56
,tex2html_wrap_inline58 and there exists an integerk,
tex2html_wrap_inline62 such thattex2html_wrap_inline64
.

The Output

For each integer pair n and p the value tex2html_wrap_inline36 should be printed, i.e., the numberk such that
tex2html_wrap_inline64 .

Sample Input

2
16
3
27
7
4357186184021382204544

Sample Output

4
3
1234

题解

这道题严格意义上要用高精度,但是其实用double型可以过,应该是数据弱的原因。

代码示例

/****
	*@PoloShen
	*Title:UVa 113
	*/
#include <cstdio>
#include <cmath>
using namespace std;
int main(){
    double n, p;
    while (scanf("%lf%lf", &n, &p) != EOF) {
        printf("%.lf\n", pow(p, 1/n));
    }
    return 0;
}

抱歉!评论已关闭.