现在的位置: 首页 > 综合 > 正文

HDU2586 How far away ?

2014年08月29日 ⁄ 综合 ⁄ 共 2496字 ⁄ 字号 评论关闭
Problem Description
There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this "How far is it if I want to go from house A to house B"? Usually it hard to answer. But luckily int this village the answer is always
unique, since the roads are built in the way that there is a unique simple path("simple" means you can't visit a place twice) between every two houses. Yout task is to answer all these curious people.
 


Input
First line is a single integer T(T<=10), indicating the number of test cases.
  For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road
connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
  Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
 


Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
 


Sample Input
2 3 2 1 2 10 3 1 15 1 2 2 3 2 2 1 2 100 1 2 2 1
 


Sample Output
10 25 100 100

Tarjan算法

/*//最近公共祖先
题目描述:给定一棵带权树,求u,v两节点的最短长度

算法思想:找到u,v两点的最近公共祖先lca(v)
若dis[u]表示根节点到u的长度,则res=dis[u]+dis[v]-2*dis[lca(v)]
*/
#include <iostream>
#include <string>
#define NN 40002 // number of house
#define MM 202   // number of query
using namespace std;

typedef struct node{
    int v;//节点
    int d;//v节点与nxt相连的权值
    struct node *nxt;
}NODE;

NODE *Link1[NN];//邻接表,Link1[u]表示与u相连所有节点链
NODE edg1[NN * 2]; // 树中的边

NODE *Link2[NN];
NODE edg2[NN * 2]; // 询问的点对

int idx1, idx2, N, M;
int res[MM][3]; // 记录结果,res[i][0]: u   res[i][1]: v  res[i][2]: lca(u, v)
int fat[NN];//并查集表
int vis[NN];//记录访问点
int dis[NN];//根到i节点的长度

//前插法
void Add(int u, int v, int d, NODE edg[], NODE *Link[], int &idx){
    edg[idx].v = v;
    edg[idx].d = d;
    edg[idx].nxt = Link[u];
    Link[u] = edg + idx++;

    edg[idx].v = u;
    edg[idx].d = d;
    edg[idx].nxt = Link[v];
    Link[v] = edg + idx++;
}

int find(int x){ // 并查集路径压缩
    if(x != fat[x]){
        return fat[x] = find(fat[x]);
    }
    return x;
}

void Tarjan(int u){
    vis[u] = 1;
    fat[u] = u;

    for (NODE *p = Link2[u]; p; p = p->nxt){
        if(vis[p->v]){
            res[p->d][2] = find(p->v); // 存的是最近公共祖先结点
        }
    }

    for (NODE *p = Link1[u]; p; p = p->nxt){
        if(!vis[p->v]){
            dis[p->v] = dis[u] + p->d;
            Tarjan(p->v);
            fat[p->v] = u;
        }
    }
}
int main() {
	freopen("C:\\in.txt","r",stdin);
    int T, i, u, v, d;
    scanf("%d", &T);
    while(T--){
        scanf("%d%d", &N, &M);

        idx1 = 0;
        memset(Link1, 0, sizeof(Link1));
        for (i = 1; i < N; i++){
            scanf("%d%d%d", &u, &v, &d);
            Add(u, v, d, edg1, Link1, idx1);
        }

        idx2 = 0;
        memset(Link2, 0, sizeof(Link2));
        for (i = 1; i <= M; i++){
            scanf("%d%d", &u, &v);
            Add(u, v, i, edg2, Link2, idx2);
            res[i][0] = u;
            res[i][1] = v;
        }

        memset(vis, 0, sizeof(vis));
        dis[1] = 0;
        Tarjan(1);

        for (i = 1; i <= M; i++){
            printf("%d\n", dis[res[i][0]] + dis[res[i][1]] - 2 * dis[res[i][2]]);
        }
    }
    return 0;
}

抱歉!评论已关闭.