现在的位置: 首页 > 综合 > 正文

HDU2176 取(m堆)石子游戏

2014年08月29日 ⁄ 综合 ⁄ 共 745字 ⁄ 字号 评论关闭
Problem Description
m堆石子,两人轮流取.只能在1堆中取.取完者胜.先取者负输出No.先取者胜输出Yes,然后输出怎样取子.例如5堆 5,7,8,9,10先取者胜,先取者第1次取时可以从有8个的那一堆取走7个剩下1个,也可以从有9个的中那一堆取走9个剩下0个,也可以从有10个的中那一堆取走7个剩下3个.
 


Input
输入有多组.每组第1行是m,m<=200000. 后面m个非零正整数.m=0退出.
 


Output
先取者负输出No.先取者胜输出Yes,然后输出先取者第1次取子的所有方法.如果从有a个石子的堆中取若干个后剩下b个后会胜就输出a b.参看Sample Output.
 


Sample Input
2 45 45 3 3 6 9 5 5 7 8 9 10 0
 


Sample Output
No Yes 9 5 Yes 8 1 9 0 10 3
 
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#include <queue>

int num[200005];
int main()
{
	freopen("C:\\in.txt","r",stdin);
	int m,t;
	while(scanf("%d",&m)!=EOF&&m){
		for(int i=0;i<m;i++)
			scanf("%d",&num[i]);
		int sum=num[0];
		for(int i=1;i<m;i++)
			sum^=num[i];
		if(sum==0)printf("No\n");
		else{
			printf("Yes\n");
			for(int i=0;i<m;i++){
				t=sum^num[i];
				if(t<num[i])
					printf("%d %d\n",num[i],t);
			}
		}
	}
	return 0;
}

抱歉!评论已关闭.