现在的位置: 首页 > 综合 > 正文

HDU1789 Doing Homework again

2014年08月29日 ⁄ 综合 ⁄ 共 1490字 ⁄ 字号 评论关闭
Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 


Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.
 


Output
For each test case, you should output the smallest total reduced score, one line per test case.
 


Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 


Sample Output
0 3 5
 

贪心算法

#include <iostream>
using namespace std;

struct homework{
	int deadline;
	int scores;
}hw[1005];

int cmp(const void *a,const void *b){
	homework *f1=(homework *)a;
	homework *f2=(homework *)b;
	return f2->scores-f1->scores;
}
int deadline[1005];
int main()
{
	freopen("C:\\in.txt","r",stdin);
	int T;
	scanf("%d",&T);
	while(T--){
		memset(deadline,0,sizeof(deadline));
		int N;
		int sum=0;
		scanf("%d",&N);
		for(int i=1;i<=N;i++)
			scanf("%d",&hw[i].deadline);
		for(int i=1;i<=N;i++)
			scanf("%d",&hw[i].scores);
		qsort(hw+1,N,sizeof(hw[0]),cmp);
		for(int i=1;i<=N;i++){
			int k=hw[i].deadline;
			while(deadline[k])k--;
			if(k==0)sum+=hw[i].scores;
			else deadline[k]=1;
		}
		printf("%d\n",sum);
	}
	return 0;
} 

抱歉!评论已关闭.