现在的位置: 首页 > 综合 > 正文

杭电1085

2014年09月05日 ⁄ 综合 ⁄ 共 1776字 ⁄ 字号 评论关闭

                                    Holding Bin-Laden Captive!

                                                  Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                     Total Submission(s): 8201    Accepted Submission(s): 3675

Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!

“Oh, God! How terrible! ”


Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem,
he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be
processed.

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.

Sample Input
1 1 3 0 0 0

Sample Output
4

Author
lcy
此题可以用贪心的方法做。
#include <stdio.h>
int main()
{
	int i,s,t,flag,d,b,c;
	int a[10];
	while(scanf("%d %d %d",&d,&b,&c)!=EOF)
	{
		if(d==0&&b==0&&c==0)
		{
			break;
		}
		for(i=1;;i++)
		{
			a[1]=d;
			a[2]=b;
			a[5]=c;
			flag=0;
			s=i;
			t=s/5;
			if(t!=0)
			{
				if(t>a[5])
				{
					s=s-a[5]*5;
					a[5]=0;
				}else
				{
					s=s-t*5;
					a[5]=a[5]-t;
					if(s==0)
					{
						flag=1;
					}
				}
			}
			t=s/2;
			if(t!=0)
			{
               if(t>a[2])
				{
					s=s-a[2]*2;
					a[2]=0;
				}else
				{
					s=s-t*2;
					a[2]=a[2]-t;
					if(s==0)
					{
						flag=1;
					}
				}
			}
			t=s/1;
            if(t!=0)
			{
               if(t>a[1])
				{
					s=s-a[1]*1;
					a[1]=0;
				}else
				{
					s=s-t*1;
					a[1]=a[1]-t;
					if(s==0)
					{
						flag=1;
					}
				}
			}
			if(flag==1)
			{
				;
			}else
			{
				break;
			}
		}
		printf("%d\n",i);
	}
	return 0;
}

抱歉!评论已关闭.