现在的位置: 首页 > 综合 > 正文

杭电1018 Big Number

2014年09月05日 ⁄ 综合 ⁄ 共 1115字 ⁄ 字号 评论关闭

                                                                       Big Number

                              Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                               Total Submission(s): 13840    Accepted Submission(s): 6157

Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number,
you have to determine the number of digits in the factorial of the number.

 

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

 

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

 

Sample Input

2

10

20

 

Sample Output

7

19

 

Source

Asia 2002, Dhaka (Bengal)

 

下面是我的代码

 

#include <stdio.h>
#include <math.h>
int main()
{
	__int64 i,n,m,s;
	double x;
	scanf("%I64d",&n);
	while(n--)
	{
		x=0;
		scanf("%I64d",&m);
		if(m==1)
		{
			s=1;
		}else
		{
			for(i=2;i<=m;i++)
			{
				x+=log10((double)(i));			
			}
			if(x==(int)(x))
			{
				s=(int)(x);
			}else
			{
				s=(int)(x)+1;
			}
		}
		printf("%d\n",s);
	}
	return 0;
}

抱歉!评论已关闭.