现在的位置: 首页 > 综合 > 正文

UVa 11300 Spreading the Wealth

2014年09月05日 ⁄ 综合 ⁄ 共 1338字 ⁄ 字号 评论关闭

注意:给定数轴上的n 个点,在数轴上的所有点中,中位数离所有顶点的距离之和最小。

 F. Spreading the Wealth 


Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided tosit everyone around a circular table. First, everyone has converted all of their properties tocoins of equal value, such that the total number of coins is divisible
by the number of people in the village. Finally, each person gives a number of coins to the person on his rightand a number coins to the person on his left, such that in the end, everyone has thesame number of coins. Given the number of coins of each person,
compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs.Each input begins with n(n<1000001), the number of people in the village.n lines follow, giving the number of coins of each person in the village, in counterclockwise order around
the table. The total number of coins will fit inside anunsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

#include <cstdio>
#include <algorithm>
using namespace std;
const int MAX = 1000000+5;

long long A[MAX], c[MAX], totl, M;
int main()
{
	int n;
	while(scanf("%d", &n)==1)
	{
		totl = 0;
		for(int i=0; i < n; i++)
		{
			scanf("%d", &A[i]);
			totl += A[i];
		}
		M = totl/n;
		c[0] = 0;
		for(int i=1; i < n; i++)
		{
			c[i] = c[i-1] + A[i] - M;
		}
		sort(c, c+n);
		long long value = c[n/2] , ans = 0;
		for(int i=0; i < n; i++)
		{
			ans += abs(value-c[i]);
		}
		printf("%lld\n", ans);
	}
	return 0;
}

抱歉!评论已关闭.