现在的位置: 首页 > 综合 > 正文

UVa 408 Uniform Generator (最大公约数&证明)

2014年09月05日 ⁄ 综合 ⁄ 共 2619字 ⁄ 字号 评论关闭

408 - Uniform Generator

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=100&page=show_problem&problem=349

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

displaymath29

where `` tex2html_wrap_inline31 " is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to
minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0
and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the sameseed(x+1) every time seed(x) occurs means that if a function will generate all
the numbers between 0 andMOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because
no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order ( tex2html_wrap_inline77 ).

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either ``Good Choice"
or ``Bad Choice" left-justified starting in column 25. The ``Good Choice" message should be printed when the selection of STEP andMOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers
are generated. Otherwise, your program should print the message ``Bad Choice". After each output test set, your program should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999

Sample Output

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice

首先可以直接暴力计算:

/*0.082s*/

#include<cstdio>

int main()
{
	int step, mod, x, count;
	while (~scanf("%d%d", &step, &mod))
	{
		x = 0, count = 0;
		do
		{
			x = (x + step) % mod;
			++count;
		}
		while (x && count != mod);
		printf("%10d%10d    %s\n\n", step, mod, count == mod && x == 0 ? "Good Choice" : "Bad Choice");
	}
	return 0;
}

利用上述代码,可以发现当mod=20时,只有1,3,7,9,11,13,17,19,...才是好的选择,而这些数都与20互质。

于是我们猜想:当gcd(step,mod)!=1时,这不是一个好的选择。

证明:设gcd(step,mod)=k,则step=ka,mod=kb,则无论怎么计算

seed(x+1) ≡ seed(x) (mod k)

所以必然有些数生成不了。

优化后的代码:

/*0.022s*/

#include<cstdio>

int gcd(int a, int b)
{
	return b ? gcd(b, a % b) : a;
}

int main()
{
	int step, mod;
	while (~scanf("%d%d", &step, &mod))
		printf("%10d%10d    %s\n\n", step, mod, gcd(step, mod) == 1 ? "Good Choice" : "Bad Choice");
	return 0;
}

抱歉!评论已关闭.