现在的位置: 首页 > 综合 > 正文

uva572 – Oil Deposits 油矿

2014年09月05日 ⁄ 综合 ⁄ 共 4144字 ⁄ 字号 评论关闭

  Oil Deposits 


The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into
numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many
different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n,
the number of rows and columns in the grid, separated by a single space. If 
m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$.
Following this are 
m lines of n characters
each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `
*', representing the absence of oil, or `@',
representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2

前段时间一直刷搜索,实在吃力,每题都得花上4小时+,菜鸟压力太大。。。

这题现在看来是题简单的dfs,很经典!

AC代码:

#include<string.h>
#include<stdio.h>

int cnt, m, n;
char map[200][200];
int ck[16] = {-1,-1, -1,0, -1,1, 0,-1, 0,1, 1,-1, 1,0, 1,1};

void mark (int x, int y)
{
	map[x][y] = '*'; 
	for (int i = 0; i < 17; i += 2)
		if (x + ck[i] >= 0 && x + ck[i] <= m & y + ck[i+1] >= 0 && y + ck[i+1] <= n && map[x + ck[i]][y + ck[i+1]] == '@')
			mark(x + ck[i], y + ck[i+1]);
	return;
}

int main()
{
	while (scanf("%d%d", &m, &n) && m != 0)
	{
		memset (map, 0, sizeof (map));
		for (int i = 0; i < m; i++)
			scanf("%s", map[i]);
		cnt = 0;
		for (int i = 0; i < m; i++)
			for (int j = 0; j < n; j++)
				if(map[i][j] == '@')
				{
					cnt++;
					mark(i, j);
				}
		printf("%d\n", cnt);
	}
	return 0;
}

  Oil Deposits 


The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into
numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many
different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n,
the number of rows and columns in the grid, separated by a single space. If 
m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$.
Following this are 
m lines of n characters
each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `
*', representing the absence of oil, or `@',
representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2

搜索还是弱项,要加强呢!

  Oil Deposits 


The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into
numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many
different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n,
the number of rows and columns in the grid, separated by a single space. If 
m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$.
Following this are 
m lines of n characters
each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `
*', representing the absence of oil, or `@',
representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2

抱歉!评论已关闭.