现在的位置: 首页 > 综合 > 正文

HDU 1069 Monkey and Banana

2014年09月05日 ⁄ 综合 ⁄ 共 2758字 ⁄ 字号 评论关闭

题目的大意是,人们对于猴子的聪明程度做了一个实验,在高处挂着香蕉然后给猴子一些箱子让他们任意的组合求最大的高度。但是要注意的是:1.给出的箱子矩形的三条边;2.每个箱子有六个面然后有三对的面积不一定相同;3.搭箱子的时候注意上面箱子的长与宽都要严格的小于下面的箱子,题目中说如果相同的话猴子就无法踩着啦。

分析完题目之后我们就会发现,只要对箱子的长与宽进行排序,解题的策略是从前面的箱子中枚举找到一个高度最合适的;

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6070    Accepted Submission(s): 3086


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 


Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 


Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 


Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 


Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342

#include <iostream>
#include <stdio.h>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

struct node
{
    int x, y, h;
} f[10100];

int cmp(node a, node b)
{
    if(a.x == b.x) return a.y < b.y;
    return a.x < b.x;
}

int main()
{
    int i, j, t, n, Max, _max;
    int a, b, c, p = 1;
    while(cin>>n && n)
    {
        t = 0;
        for(i = 0; i < n; i++)
        {
            cin >>a>>b>>c;
            f[t].x = a, f[t].y = b, f[t++].h = c;
            f[t].x = b, f[t].y = a, f[t++].h = c;
            f[t].x = a, f[t].y = c, f[t++].h = b;
            f[t].x = c, f[t].y = a, f[t++].h = b;
            f[t].x = b, f[t].y = c, f[t++].h = a;
            f[t].x = c, f[t].y = b, f[t++].h = a;
        }
        sort(f , f+t, cmp);
        _max = f[0].h;
        for(i = 1; i < t; i++)
        {
            Max = 0;
            for(j = 0; j < i; j++)//从前边找到一个符合要求的底面积最大的
                if(f[i].x > f[j].x && f[i].y > f[j].y)
                    Max = max(Max,f[j].h);
            f[i].h += Max;
            _max = max(_max,f[i].h);
        }
        printf("Case %d: maximum height = %d\n",p++, _max);
    }
    return 0;
}

抱歉!评论已关闭.