现在的位置: 首页 > 综合 > 正文

poj 2503 Babelfish

2014年09月05日 ⁄ 综合 ⁄ 共 1171字 ⁄ 字号 评论关闭

这道题周赛做过啊,map 水过啊、、

Babelfish
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 28620   Accepted: 12343

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears
more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops
#include <iostream>
#include <stdio.h>
#include <map>
#include <string>
#include <string.h>

using namespace std;

int main()
{
    map<string,string> map1;
    char a[50],b[20],c[20];
    while(gets(a)&&a[0]!='\0')
    {
        sscanf(a,"%s %s",b,c);
        map1[c]=b;
    }
    while(gets(a)&&a[0]!='\0')
    {
        if( map1.find(a)==map1.end())
            cout <<"eh"<<endl;
        else
            cout <<map1[a]<<endl;
    }
    return 0;
}

抱歉!评论已关闭.