现在的位置: 首页 > 综合 > 正文

poj 1936 All in All

2014年09月05日 ⁄ 综合 ⁄ 共 1433字 ⁄ 字号 评论关闭

这道题大体就是找子串、、很水的啊,暴力就可过掉啊、、示例很清晰啊、、

All in All
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 25673   Accepted: 10355

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into
the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No
#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

char s[101000], str[101000];
int main()
{
    int i, j, t, k1, k2, sum;
    while(~scanf("%s %s",s, str))
    {
        k1 = strlen(s);
        k2 = strlen(str);
        if(k1 > k2)
            printf("No\n");
        else if(k1 == k2)
        {
            if(strcmp(s,str) == 0)
                printf("Yes\n");
            else
                printf("No\n");
        }
        else
        {
            sum = 0;
            t = 0;
            for(i = 0; i < k1; i++)
            {
                int flat = 1;
                for(j = t; j < k2; j++)
                {
                    if(s[i] == str[j])
                    {
                        t = j+1;
                        flat = 0;
                        sum++;
                        break;
                    }
                }
                if(flat)
                {
                    printf("No\n");
                }
            }
            if(sum == k1)
                printf("Yes\n");
        }
    }
    return 0;
}

抱歉!评论已关闭.