现在的位置: 首页 > 综合 > 正文

POJ 3080 Blue Jeans

2014年09月05日 ⁄ 综合 ⁄ 共 2593字 ⁄ 字号 评论关闭

一开始我以为是字典树的啊、、后来发现没有思路啊、、看了discuss后知道了可以暴力过掉、、可是自己敲的时候竟然连样例都没有过掉啊、、后来发现思路是不对的啊、、看了discuss里的代码,感觉写的真不错啊、、、就学习了啊,就很轻松的过掉了啊、、由于我是菜鸟这是我第一次使用strstr函数、、也在这里纪念一下啊、、呵呵、、

Blue Jeans
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10157   Accepted: 4305

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences
of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT
#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

int main()
{
    char str[20][100], st[100], s[100];
    int i, j, n, m, k, h, num, ans, len;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d",&m);
        getchar();
        for(i = 0; i < m; i++)
            gets(str[i]);
        len = strlen(str[0]);
        ans = 0;
        for(i = 0; i < len; i++)
        {
            for(j = i; j < len; j++)
            {
                num = 0;
                for(k = i; k <= j; k++)
                    st[num++] = str[0][k];
                st[num] = 0;
                for(h = 1; h < m; h++)
                    if(strstr(str[h] , st) == 0)
                        break;
                if(h == m && ans < num)
                {
                    ans = num;
                    strcpy(s,st);
                }
                else if(h == m && ans == num)
                {
                    if(strcmp(s,st) > 0)
                        strcpy(s,st);
                }
            }
        }
        if(ans < 3)
            printf("no significant commonalities\n");
        else puts(s);
    }
    return 0;
}

抱歉!评论已关闭.