现在的位置: 首页 > 综合 > 正文

HDU 1701

2014年09月05日 ⁄ 综合 ⁄ 共 711字 ⁄ 字号 评论关闭

ACMer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3388    Accepted Submission(s): 1554


Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 


Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 


Output
For each test case, output the minumal number of students in HDU.
 


Sample Input
1 13.00 14.10
 


Sample Output
15
 
题解:一道简单题。
AC code:
#include <iostream>
using namespace std;
int main()
{
	int n;
	double a,b;
	cin>>n;
	while(n--)
	{
		cin>>a>>b;
		for(int i=1;;i++)
		{
			if(int(a*i)/100<int(b*i)/100)
				break;
		}
		cout<<i<<endl;
	}
	return 0;
}

抱歉!评论已关闭.