现在的位置: 首页 > 综合 > 正文

UVA 107 The Cat in the Hat

2014年09月05日 ⁄ 综合 ⁄ 共 2434字 ⁄ 字号 评论关闭

 The Cat in the Hat 


Background

(An homage to Theodore Seuss Geisel)

The Cat in the Hat is a nasty creature,
But the striped hat he is wearing has a rather nifty feature.

With one flick of his wrist he pops his top off.

Do you know what's inside that Cat's hat?
A bunch of small cats, each with its own striped hat.

Each little cat does the same as line three,
All except the littlest ones, who just say ``Why me?''

Because the littlest cats have to clean all the grime,
And they're tired of doing it time after time!

The Problem

A clever cat walks into a messy room which he needs to clean. Instead of doing the work alone, it decides to have its helper cats do the work. It keeps its (smaller) helper cats inside its hat. Each helper cat also has helper cats in its own hat, and so on.
Eventually, the cats reach a smallest size. These smallest cats have no additional cats in their hats. These unfortunate smallest cats have to do the cleaning.

The number of cats inside each (non-smallest) cat's hat is a constant, N. The height of these cats-in-a-hat is tex2html_wrap_inline35 times the
height of the cat whose hat they are in.

The smallest cats are of height one; 
these are the cats that get the work done.

All heights are positive integers.

Given the height of the initial cat and the number of worker cats (of height one), find the number of cats that are not doing any work (cats of height greater than one) and also determine the sum of all the cats' heights (the height of a stack of all cats standing
one on top of another).

The Input

The input consists of a sequence of cat-in-hat specifications. Each specification is a single line consisting of two positive integers, separated by white space. The first integer is the height of the initial cat, and the second integer is the number of worker
cats.

A pair of 0's on a line indicates the end of input.

The Output

For each input line (cat-in-hat specification), print the number of cats that are not working, followed by a space, followed by the height of the stack of cats. There should be one output line for each input line other than the ``0 0'' that terminates input.

Sample Input

216 125
5764801 1679616
0 0

Sample Output

31 671
335923 30275911
题目超级复杂,应该是今天刷题用时最多的一道了吧,最后还是参考网上答案的方法,才做出来。
之前我写的是先求i再求n,但是提交超时。
改成先求n再求i就可以了,但是类型转换真的好烦啊啊啊啊啊啊啊啊!!!!
今天是集训第一天,从早上九点到晚上七点一共刷了10题,应该是比较领先的~
嘚瑟一个
一会接着复习数电、预习离散。
谁让我是学霸呢~
代码如下:
#include <stdio.h>
#include <math.h>
int main(void)
{
    int n,sumh,t1,t2;
    int h,i,k,cats;
    
    while(scanf("%d%d",&h,&k)!=EOF&&(h||k))
    {
     n=1;
     while(fabs((log((double)k)/log((double)h))-(log((double)n))/log((double)(n+1)))>1e-9)
      n++;
     i=(int)(0.5+log((double)h)/log((double)(n+1)));
     if(n==1)
     {
      printf("%d %d\n",i,(int)(0.5+h*(1-pow(((double)n/(1+n)),i+1))/(double)(1-((double)n)/(1+n))));  
      continue;
     }
     sumh=h;
     cats=1;
     t1=1;t2=1;  
     while(i--)
     {
      t1*=n;
      t2*=(n+1);
      sumh+=h/t2*t1;
      cats+=t1;
     }
     printf("%d %d\n",cats-k,sumh);
    }
    return 0;
}
            

抱歉!评论已关闭.