现在的位置: 首页 > 综合 > 正文

UVA 591 Box of Bricks

2014年09月05日 ⁄ 综合 ⁄ 共 2645字 ⁄ 字号 评论关闭

  Box of Bricks 


Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have
a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number
of bricks moved. Can you help?

Input 

The input consists of several data sets. Each set begins with a line containing the number n of
stacks Bob has built. The next line contains
n numbers,
the heights 
hi of
the 
n stacks. You may assume $1 Ÿ\le n \leŸ 50$ and $1 \leŸ h_i Ÿ\le 100$.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The
minimum number of moves is
k.'', where k is
the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input 

6
5 2 4 1 7 5
0

Sample Output 

Set #1
The minimum number of moves is 5.

求得所有数和平均值的差值,将正数加在一起即可

代码如下:

#include <stdio.h>
int main(void)
{
    int n,k,i,ave,sum;
    int a[55],b[55];
    int flag=1;
    
    while(scanf("%d",&n)!=EOF&&n)
    {
     sum=0;k=0;
     for(i=0;i<n;i++)
     {
      scanf("%d",&a[i]);
      sum+=a[i];
     }
     ave=sum/n;
     for(i=0;i<n;i++)
      b[i]=a[i]-ave;
     for(i=0;i<n;i++)
      if(b[i]>0)
       k+=b[i];
     printf("Set #%d\n",flag++);
     printf("The minimum number of moves is %d.\n\n",k);
    }
    return 0;
} 

  Box of Bricks 


Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have
a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number
of bricks moved. Can you help?

Input 

The input consists of several data sets. Each set begins with a line containing the number n of
stacks Bob has built. The next line contains
n numbers,
the heights 
hi of
the 
n stacks. You may assume $1 Ÿ\le n \leŸ 50$ and $1 \leŸ h_i Ÿ\le 100$.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output 

For each set, first print the number of the set, as shown in the sample output. Then print the line ``The
minimum number of moves is
k.'', where k is
the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line after each set.

Sample Input 

6
5 2 4 1 7 5
0

Sample Output 

Set #1
The minimum number of moves is 5.

抱歉!评论已关闭.