现在的位置: 首页 > 综合 > 正文

HDU1208:Pascal’s Travels(DP)

2014年09月05日 ⁄ 综合 ⁄ 共 1995字 ⁄ 字号 评论关闭
Problem Description
An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one
square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is
a dead end which prevents any further progress. 

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 



Figure 1




Figure 2
 


Input
The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number
of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.
 


Output
The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 
 


Sample Input
4 2331 1213 1231 3110 4 3332 1213 1232 2120 5 11101 01111 11111 11101 11101 -1
 


Sample Output
3 0 7
Hint
Hint
Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as "__int64" values using the Visual C/C++ or "long long" values using GNU C/C++ or "int64" values using Free Pascal compilers.
 

 

题意:每一个代表下次能横向或者纵向走几步,问从左上走到右下要走几步

思路:一道DP题,dp数组用来存放到达坐标i,j,要走的步数即可,并没要求最大或者最小

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,i,j,k;
__int64 dp[40][40];
int map[40][40];
char s[40];

int main()
{
    while(~scanf("%d",&n),n+1)
    {
        for(i = 0; i<n; i++)
        {
            scanf("%s",s);
            for(j = 0; j<n; j++)
            {
                map[i][j] = s[j]-'0';
            }
        }
        memset(dp,0,sizeof(dp));
        dp[0][0] = 1;
        for(i = 0; i<n; i++)
        {
            for(j = 0; j<n; j++)
            {
                if(!map[i][j] || !dp[i][j])
                    continue;
                if(i+map[i][j]<n)//不越界
                    dp[i+map[i][j]][j]+=dp[i][j];
                if(j+map[i][j]<n)
                    dp[i][j+map[i][j]]+=dp[i][j];
            }
        }
        printf("%I64d\n",dp[n-1][n-1]);
    }
    return 0;
}

 

抱歉!评论已关闭.