现在的位置: 首页 > 综合 > 正文

POJ1651:Multiplication Puzzle(区间DP)

2014年09月05日 ⁄ 综合 ⁄ 共 1380字 ⁄ 字号 评论关闭

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the
card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650
 
题意:一系列的数字,除了头尾不能动,每次取出一个数字,这个数字与左右相邻数字的乘积为其价值,最后将所有价值加起来,要求最小值
思路:求出每个区间的最小值,一直扩散到整个区间
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,a[105],dp[105][105],i,j,k,l;

int main()
{
    while(~scanf("%d",&n))
    {
        for(i = 1; i<=n; i++)
            scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(l = 2; l<n; l++)//长度从2开始枚举
        {
            for(i = 2; i+l<=n+1; i++)
            {
                j = i+l-1;
                dp[i][j] = 100000000;
                for(k = i; k<j; k++)//枚举中点
                    dp[i][j] = min(dp[i][j],dp[i][k]+dp[k+1][j]+a[i-1]*a[k]*a[j]);
            }
        }
        printf("%d\n",dp[2][n]);
    }

    return 0;
}

抱歉!评论已关闭.