现在的位置: 首页 > 综合 > 正文

HDU2134:Cuts the cake

2014年09月05日 ⁄ 综合 ⁄ 共 942字 ⁄ 字号 评论关闭
Problem Description
Ice cream took a bronze medal in the Beijing match. Liu sir is very very happy. So he buys a cake for them. kiki is a child who likes eating, so the task of cuting cake was given to kiki. kiki is also a mischievous child. She wants
to cut the cake in a different way. This is introduced in the figure below.


But there is a difficult problem.which is how to make each preson get equally many cake. kiki is not good at match, so she wants you help her solve this problem. 
 

Input
Input contains multiple test cases. Each line is a case. Each case contains only one integer R which is the radius. The input is terminated with a R of 0.
 

Output
For each test case, you should printf two numbers r2 and r1 in a line, accurate up to 3 decimal places, separate them by one space.
 

Sample Input
10 15 5 25 0
 

Sample Output
5.774 8.165 8.660 12.247 2.887 4.082 14.434 20.412
 

 

题意就只把蛋糕切成面积相等的三等分,求里面两个的半径,果断水题

 

#include <stdio.h>
#include <math.h>
# define pi 3.1415926

int main()
{
    double r,r1,r2,s;
    while(~scanf("%lf",&r),r)
    {
        s = pi*r*r;
        r1 = sqrt(s/3.0/pi);
        r2 = sqrt(2.0/3.0*s/pi);
        printf("%.3lf %.3lf\n",r1,r2);
    }

    return 0;
}

 

抱歉!评论已关闭.