现在的位置: 首页 > 综合 > 正文

HDU4716:A Computer Graphics Problem

2014年09月05日 ⁄ 综合 ⁄ 共 1780字 ⁄ 字号 评论关闭
Problem Description
In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.
We have designed a new mobile phone, your task is to write a interface to display battery powers.
Here we use '.' as empty grids.
When the battery is empty, the interface will look like this:
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this:

*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters.
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.

 


Input
The first line has a number T (T < 10) , indicating the number of test cases.
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 


Output
For test case X, output "Case #X:" at the first line. Then output the corresponding interface.
See sample output for more details.
 


Sample Input
2 0 60
 


Sample Output
Case #1: *------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------* Case #2: *------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*
 

 

水题不解释

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int main()
{
    int T,cas = 1,n,i,j;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        printf("Case #%d:\n",cas++);
        printf("*------------*\n");
        for(i = 0;i<10-n/10;i++)
        printf("|............|\n");
        for(i = 0;i<n/10;i++)
        printf("|------------|\n");
        printf("*------------*\n");
    }

    return 0;
}

 

抱歉!评论已关闭.