现在的位置: 首页 > 综合 > 正文

杭电 1312 Red and Black

2014年10月28日 ⁄ 综合 ⁄ 共 2128字 ⁄ 字号 评论关闭

http://acm.hdu.edu.cn/showproblem.php?pid=1312

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6074    Accepted Submission(s): 3863


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 


Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 


Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 


Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 


Sample Output
45 59 6 13
 
这题可用深搜也可用广搜,我用的广搜(BFS),第一次用广搜,好蛋疼,写了几个小时。。。终于搞定了。。
我一开始一直不对,是因为入队时没有处理好,让一个点重复入队几次,导致搜索次数大大增加,总是不对。。哭。。。
AC代码:
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
using namespace std;

struct Node
{
    int x,y;
};

char map[25][25];
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};

int Bfs(Node p)
{
    Node next;
    Node now;
    int cnt,i;
    queue<Node> q;
    q.push(p);
    cnt = 0;
    map[p.x][p.y] ='#';
    while(!q.empty())
    {
        now= q.front();
        q.pop();
        cnt++;
        for(i = 0; i < 4; i++)
        {
            next.x = now.x+dir[i][0];
            next.y = now.y+dir[i][1];
            if(map[next.x][next.y] == '.')
            {
                map[next.x][next.y] = '#';  //入队时标记已入队,防止重复入队
                q.push(next);
            }
        }
    }
    return cnt;
}

int main()
{
    Node p;
    int n,m,time,i,j,x,y;
    while(scanf("%d%d",&n,&m),n&&m)
    {
        memset(map,'#',sizeof(map));
        for(i = 1; i <= m; i++)  //输入
        {
            getchar();
            for(j = 1; j <= n; j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j] == '@')
                {
                    p.x = i;
                    p.y = j;
                    map[i][j] = '.';
                }
            }
        }
        time = Bfs(p);
        printf("%d\n",time);
    }

    return 0;
}

抱歉!评论已关闭.