现在的位置: 首页 > 综合 > 正文

POJ训练计划1789_Truck History(最小生成树)

2015年01月16日 ⁄ 综合 ⁄ 共 2689字 ⁄ 字号 评论关闭
Truck History
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16797   Accepted: 6442

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 

1/Σ(to,td)d(to,td)


where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

解题报告
POJ训练计划--最小生成树第一题。
题意
给几个字符串,
每个字符串都只有 7 个字符,
两个字符串的距离就是数出对应位置不同的字符个数。
求最小生成树。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define inf 99999999
using namespace std;
char mmap[2010][10];
int mapp[2010][2010];
int n;
void prim()
{
    int dis[2010],u,minn,i,j,ans=0;
    int vis[2010];
    for(i=0; i<n; i++)
    {
        dis[i]=mapp[0][i];
        vis[i]=0;
    }
    dis[0]=0;
    vis[0]=1;
    for(i=0; i<n-1; i++)
    {
        u=0;
        minn=inf;
        for(j=0; j<n; j++)
        {
            if(!vis[j]&&dis[j]<minn)
            {
                minn=dis[j];
                u=j;
            }
        }
        vis[u]=1;
        ans+=minn;
        for(j=0; j<n; j++)
        {
            if(!vis[j]&&mapp[u][j]<dis[j])
            {
                dis[j]=mapp[u][j];
            }
        }
    }
    cout<<"The highest possible quality is 1/"<<ans<<"."<<endl;
}
int main()
{
    int i,j,k;
    while(cin>>n,n)
    {
        memset(mapp,0,sizeof(mapp));
        for(i=0; i<n; i++)
            cin>>mmap[i];
        for(i=0; i<n; i++)
        {
            for(j=0; j<n; j++)
            {
                for(k=0; k<7; k++)
                    if(mmap[i][k]!=mmap[j][k])
                    {
                        mapp[i][j]++;
                    }
            }
        }
//        for(i=0; i<n; i++)
//        {
//            for(j=0; j<n; j++)
//                cout<<mapp[i][j]<<" ";
//            cout<<endl;
//        }
        prim();
    }
    return 0;
}

抱歉!评论已关闭.