现在的位置: 首页 > 综合 > 正文

【ACM Steps】 Fibonacci

2015年02月12日 ⁄ 综合 ⁄ 共 879字 ⁄ 字号 评论关闭

Fibonacci

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1804 Accepted Submission(s): 880
 
Problem Description
2007年到来了。经过2006年一年的修炼,数学神童zouyu终于把0到100000000的Fibonacci数列
(f[0]=0,f[1]=1;f[i] = f[i-1]+f[i-2](i>=2))的值全部给背了下来。
接下来,CodeStar决定要考考他,于是每问他一个数字,他就要把答案说出来,不过有的数字太长了。所以规定超过4位的只要说出前4位就可以了,可是CodeStar自己又记不住。于是他决定编写一个程序来测验zouyu说的是否正确。
 
Input
输入若干数字n(0 <= n <= 100000000),每个数字一行。读到文件尾。
 
Output

            输出f[n]的前4个数字(若不足4个数字,就全部输出)。
 
Sample Input
0
1
2
3
4
5
35
36
37
38
39
40
 
Sample Output
0
1
1
2
3
5
9227
1493
2415
3908
6324
1023
 
Author
daringQQ
 
#include <iostream>
#include <cmath>
using namespace std;

int a[40];


int main()
{
	a[0]=0;
	a[1]=1;
	for(int i=2;i<21;i++)
	{
		a[i]=a[i-1]+a[i-2];
	}
	int n;
	double f,p;
	f=(1.0+sqrt(5.0))/2;
	
	while(cin>>n)
	{
		if(n<21)
		{
			cout<<a[n]<<endl;
			continue;
		}
		
		p=-0.5*log10(5.0)+n*1.0*log(f)/log(10.0);  
        p=p-floor(p);  
        p=pow(10.0,p);  
        while(p<1000)  
            p*=10;  
        int ans=p;
        cout<<ans<<endl;
	}

   return 0;	
} 

抱歉!评论已关闭.