现在的位置: 首页 > 综合 > 正文

HDU 1325 Is It A Tree?

2012年02月04日 ⁄ 综合 ⁄ 共 2496字 ⁄ 字号 评论关闭

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6961    Accepted Submission(s): 1619

Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 

 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 

 

Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

 

Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 

 

Source
 

 

Recommend
Ignatius.L
 
 
 
 
 
好像可以用并查集做的。。。
但是我直接统计入度也可以出来。。。
虽然是有问题的,但是AC  了。。数据有漏洞呢。。嘻嘻~~~
 
#include<stdio.h>
#include<string.h>
using namespace std;

const int MAXN=1000;
int heap[MAXN];
int in[MAXN],out[MAXN];
int main()
{
    int cnt=0;
    int i;
    int a,b;
    int iCase=0;
    while(scanf("%d%d",&a,&b))
    {
        iCase++;
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        if(a<0&&b<0) break;
        if(a==0&&b==0)
        {
            printf("Case %d is a tree.\n",iCase);
            continue;
        }
        int cnt=0;
        
        for(i=0;i<cnt;i++)
        if(heap[i]==a)break;
        if(i>=cnt)
        {
                heap[cnt]=a;
                out[cnt++]=1;
        }    
        else out[i]++;
        for(i=0;i<cnt;i++)
        if(heap[i]==b)break;
        if(i>=cnt)
        {
                heap[cnt]=b;
                in[cnt++]=1;
        }    
        else in[i]++;
        
        while(scanf("%d%d",&a,&b))
        {
            if(a==0&&b==0) break;
            for(i=0;i<cnt;i++)
              if(heap[i]==a)break;
            if(i>=cnt)
            {
                heap[cnt]=a;
                out[cnt++]=1;
            }    
            else out[i]++;
            for(i=0;i<cnt;i++)
              if(heap[i]==b)break;
            if(i>=cnt)
            {
                heap[cnt]=b;
                in[cnt++]=1;
            }    
            else in[i]++;
        }     
        int in0=0,in1=0;
        for(int i=0;i<cnt;i++)
        {
            if(in[i]==0) in0++;
            if(in[i]==1) in1++;
        }           
        if(in0==1&&in1==cnt-1) printf("Case %d is a tree.\n",iCase);
        else printf("Case %d is not a tree.\n",iCase);
    }        
    return 0;
}    

 

抱歉!评论已关闭.