现在的位置: 首页 > 综合 > 正文

【PAT 1055】The World’s Richest 结构体排序&剪枝

2017年05月08日 ⁄ 综合 ⁄ 共 3035字 ⁄ 字号 评论关闭

1055. The World's Richest (25)

时间限制
200 ms
内存限制
128000 kB
代码长度限制
16000 B
判题程序
Standard

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths
of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines
follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines
of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It
is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题意:

给出富翁名单及年龄、财富值,求在某个年龄区间的最富有的M个富翁名单。

分析:

先进行Person结构体排序;由于题目中M的值小于等于100,所以某个年龄出现的次数大于一百的时候可以过滤掉。如果不这样做,Case 2会超时。

代码:


#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <cstdio>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

struct Person{
	char name[9];
	int age;
	int worth;
}*p;

bool resCmp(const Person& a,const Person& b){
	if(a.worth == b.worth){
		if(a.age == b.age){
			if(strcmp(a.name,b.name)>0)
				return false;
			else 
				return true;
		}else{
			return a.age < b.age;
		}
	}else{
		return a.worth > b.worth;
	}
}

int main()
{
	int n,k;
	scanf("%d %d",&n,&k);
	//cin>>n>>k;
	p = new Person[n];
	int i,j,z;
	for(i=0;i<n;i++){
		scanf("%s %d %d",p[i].name,&p[i].age,&p[i].worth);
		//cin>>p[i].name>>p[i].age>>p[i].worth;
	}
	sort(p,p+n,resCmp);
	int ageCount[201]={0};
	int *filter = new int[n];
	int filter_num = 0;
	for(i=0;i<n;i++){
		if(++ageCount[p[i].age] < 101){
			filter[filter_num++] = i;
		}
	}
	int count;
	int m,amin,amax;
	bool flag;
	int unfilter;
	for(i=0;i<k;i++){
		scanf("%d %d %d",&m,&amin,&amax);
		//cin>>m>>amin>>amax;
		count = 0;
		flag = true;
		printf("Case #%d:\n",i+1);
		for(j=0;j<filter_num;j++){
			unfilter = filter[j];
			if(p[unfilter].age >= amin && p[unfilter].age<= amax){
				printf("%s %d %d\n",p[unfilter].name,p[unfilter].age,p[unfilter].worth);
				flag = false;
				count ++;
				if(count >= m){break;}
			}
		}
		if(flag)printf("None\n");
	}
	system( "PAUSE");
	return 0;
}

抱歉!评论已关闭.