现在的位置: 首页 > 综合 > 正文

hdu 题目1241 Oil Deposits(简单DFS)

2017年06月03日 ⁄ 综合 ⁄ 共 1992字 ⁄ 字号 评论关闭

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8179    Accepted Submission(s): 4792

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

 

Sample Input
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 
Sample Output
0 1 2 2
 

 

原理和HDU1312 一样

 

 

#include <iostream>
#include <stdio.h>

using namespace std;


int m,n,cnt;
char a[102][102];

void DFS(int x,int y)
{
	a[x][y] = '*';
	
	if( x+1<m && a[x+1][y]=='@' ) DFS(x+1,y);
	if( y+1<n && a[x][y+1]=='@' ) DFS(x,y+1);
	if( x-1>=0 && a[x-1][y]=='@' ) DFS(x-1,y);
	if( y-1>=0 && a[x][y-1]=='@' ) DFS(x,y-1);
	
	if( x+1<m && y+1<n  && a[x+1][y+1]=='@' ) DFS(x+1,y+1);
	if( x-1>=0 && y-1>=0  && a[x-1][y-1]=='@' ) DFS(x-1,y-1);
	if( x+1<m && y-1>=0  && a[x+1][y-1]=='@' ) DFS(x+1,y-1);
	if( x-1>=0 && y+1<n  && a[x-1][y+1]=='@' ) DFS(x-1,y+1);
		
}
int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n),m)
	{
		for(i=0;i<m;i++)
			scanf("%s",a[i]);	
		
		
		cnt=0;
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				if(a[i][j]=='@')
				{
					DFS(i,j);cnt++;
				}				
			}
		}
	
		printf("%d\n",cnt);
	}
	return 0;
}

 

抱歉!评论已关闭.