现在的位置: 首页 > 综合 > 正文

poj 题目2318 TOYS (计算几何,点与边的关系)

2017年06月04日 ⁄ 综合 ⁄ 共 2831字 ⁄ 字号 评论关闭
TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9018 Accepted: 4288

Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the
toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example
toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates
of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2).
You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of
the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from
0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

 

 

1.从左到有有右将每条边都存起来,然后输入一个点判断一个;

2.判断一个点的所属区域时,首先从第一条边开始判断,如果该点在第一条边左边 ,则所属区域为边左边的区域,跳出循环,判断下一个点; 若不在第一条边的左边,则继续循环

3.判断点与边的关系的时候,用叉积 判断;

 

#include<stdio.h>
#define N 50005

struct point{
	int x,y; //本题这里y坐标多余 
};
struct bian{
	point up,down;//边的上下顶点 
};
bian box[N];  int cnt[N];

int main()
{
	int n,m,x1,y1,x2,y2,i,j,xj,yj,ui,li;
	while(scanf("%d",&n),n)
	{
		scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);

		box[n].up.x = box[n].down.x = x2;
		box[n].up.y = y1; box[n].down.y = y2; //这里有点多余,所有的点纵坐标都是 y1或y2 
		for(i=0;i<n;i++){
			scanf("%d%d",&ui,&li);
			box[i].up.x = ui; box[i].up.y = y1;
			box[i].down.x=li; box[i].down.y = y2;
		}
		for(i=0;i<=n;i++) cnt[i]=0; //初始化数组 
		for(i=0;i<m;i++){
			scanf("%d%d",&xj,&yj);
			for(j=0;j<=n;j++) {	//查找区域
				int b1x = box[j].up.x ;
				int b2x = box[j].down.x;	
				if((b2x-b1x)*(yj-y1)-(y2-y1)*(xj-b1x)<0 ) {
					cnt[j]++; break;	
				}
			}
		}			
		for(i=0;i<=n;i++)
			printf("%d: %d\n",i,cnt[i]);
		puts("");
	}
	return 0;
}

 

 

抱歉!评论已关闭.