现在的位置: 首页 > 综合 > 正文

nyoj412 Same binary weight(bitset类运用)

2017年06月06日 ⁄ 综合 ⁄ 共 1057字 ⁄ 字号 评论关闭


bitset类:http://blog.163.com/lixiangqiu_9202/blog/static/53575037201251121331412/

Same binary weight

时间限制:300 ms  |  内存限制:65535 KB
难度:3
描述

The binary weight of a positive  integer is the number of 1's in its binary representation.for example,the decmial number 1 has a binary weight of 1,and the decimal number 1717 (which is 11010110101 in binary) has a binary weight of 7.Give a positive integer
N,return the smallest integer greater than N that has the same binary weight as N.N will be between 1 and 1000000000,inclusive,the result is guaranteed to fit in a signed 32-bit interget.

输入
The input has multicases and each case contains a integer N.
输出
For each case,output the smallest integer greater than N that has the same binary weight as N.
样例输入
1717
4
7
12
555555
样例输出
1718
8
11
17
555557
来源
topcoder
上传者

骆魁永

思路:

1.从右往左的第一对01互换位置

2.把右边的所有1都移到最右边

#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#include<bitset>
using namespace std;

int main()
{
    int n;
    while(cin>>n)
    {
        bitset<32>tp(n);
        int i,j,cnt=0;
        for(i=0;i<32;++i)
        {
            if(tp[i]) ++cnt;
            if(tp[i]&&!tp[i+1])
            {
                tp[i]=false;
                tp[i+1]=true;
                j=i;
                break;
            }
        }

        --cnt;
        for(i=0;i<cnt;++i) tp[i]=true;

        while(i<j) tp[i++] =0;

        cout<<tp.to_ulong()<<endl;
    }
}


【上篇】
【下篇】

抱歉!评论已关闭.