现在的位置: 首页 > 综合 > 正文

Train Problem I(STL)基本运用stack

2017年06月06日 ⁄ 综合 ⁄ 共 1892字 ⁄ 字号 评论关闭

Train Problem I

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
描述
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius
Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway
first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered
from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

输入
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input
is terminated by the end of file. More details in the Sample Input.
输出
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting
into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
样例输入
3 123 321
3 123 312
样例输出
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH
来源
POE_Crazy
上传者
张洁烽

题意:给你一个数字n(字符串长度) str1是否可以变成str2?如何过可以yes 输出炒作过程
比较坑的一点就是 str2的长度可能大于str1

于是str1[i] 压入栈标记为1 如果栈顶==str2[j] 就出栈 j++ 标记为0
j==n yes 否则 no
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stack>
using namespace std;

int main()
{
    int n;int vis[150];
    char str1[150],str2[150];
    
    stack<char>tp;
    
    while(~scanf("%d %s %s",&n,str1,str2))
    {
        memset(vis,0,sizeof(vis));
        int j=0,k=0;
        for(int i=0;i<n;i++)
        {
            tp.push(str1[i]);
            vis[k++]=1;
            while(!tp.empty()&&tp.top()==str2[j])
            {
                vis[k++]=0;
                tp.pop();
                j++;
            }
        }
        if(j==n)
        {
            printf("Yes.\n");
            for(int i=0;i<k;i++)
            {
                if(vis[i])
                    printf("in\n");
                else
                    printf("out\n");
            }
            printf("FINISH\n");
        }
        else
            printf("No.\nFINISH\n");
    }
}

抱歉!评论已关闭.